Skip Navigation

[Resolved] CRED notification fields showing empty values

This support ticket is created 8 years ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 -
- 13:00 – 18:00 13:00 – 18:00 13:00 – 18:00 14:00 – 18:00 13:00 – 18:00 -

Supporter timezone: America/Jamaica (GMT-05:00)

This topic contains 4 replies, has 2 voices.

Last updated by Shane 8 years ago.

Assisted by: Shane.

Author
Posts
#402827

Hi, I've in my CRED form a field like:

[cred_field field='solicitud-email' post='solicitud' value='' urlparam='' placeholder='Email']

Then I want to display its value in a notification mail.

I found here the same problem:

https://toolset.com/forums/topic/cred-commerce-notification-send-empty-field-data/
https://toolset.com/forums/topic/cred-notification-fields-showing-empty-values/

I tried:

[types field="solicitud-zona"][/types]

[types field="wpcf-solicitud-zona"][/types]

[types field="wpcf-solicitud-zona" id="%%POST_ID%%"][/types]

The result is an empty value in the notification mail body.

I also tried:

[wpv-post-field name='wpcf-solicitud-zona']

It gave me this output in the notificaion:

Array, Array, Array, Array, Array, Array, Array, Array, Array, Array

what can I do?

thanks

#402914

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Umberto,

Thank you for contacting our support forum.

Could you try doing this.

[types field="solicitud-zona" id="%%POST_ID%%"][/types]

Please try this and let me know if this helps.
Thanks,
Shane

#402915

Hi Shane, It still doesn't work.

#403111

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Umberto,

Thats strange as this should work.

Would you mind providing me with admin access to the website so that I can test it out ?

The private fields will be enabled for your next response.

Thanks,
Shane

#403504

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Umberto,

I believe i've found the suspect.

It seems you have used the type attribute wrongly 🙁 where i see on your generic fields you have type="hidden"

Unfortunately type="hidden" is not a field type. This can only be of types checkbox, textfield,radio etc

I believe that this is why its not being passed onto the notification. Because the fields aren't being rendered and when I check the post request for the form, the generic fields are missing as well.

Thanks,
Shane

This ticket is now closed. If you're a Toolset client and need related help, please open a new support ticket.