Skip Navigation

[Resolved] CRED: Edit screen is blank and attaching to parent

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Adriano 6 years, 11 months ago.

Assigned support staff: Adriano.

Author
Posts
#150173

Hi,

I have added custom post type called deals. On my page I have a the following shortcode:

[cred_form form="Current Deals (Add)"]

The form submits successfully, and I verified the form is in wp-admin and correctly attached to the specific author of the content.

On the same page I have inserted a short code to show all the current deal listings the author has published. This displays correctly, however, when I click to edit the link goes to a blank page with no way to edit. The code I am using is the following with the query filter set to "Select posts with the author the same as the current logged in user."

[wpv-layout-start]
	[wpv-items-found]
	<!-- wpv-loop-start -->
          <h3>Fill in the form below to edit a current deal</h3>
		<ul>
		<wpv-loop>
                   <li>[cred_link_form form="Business Directory (Edit)" text="Edit %TITLE%" target="_self"]</li>
		</wpv-loop>
       </ul>  
	<!-- wpv-loop-end -->
	[/wpv-items-found]
	[wpv-no-items-found]
		[wpml-string context="wpv-views"]<strong>No items found</strong>[/wpml-string]
	[/wpv-no-items-found]
[wpv-layout-end]

Can you please lend some insight on this? Thank you!

Additionally, the Current Deal the user is submitting are meant to be connected to a business listing. How can I go about connecting this Current Deal to a parent business listing already in the system?

Thank you very much,
Michael

#150289

Dear Sammut,

I think that it is a handled bug. Please check your email, I sent a fix patch for you by there. Please update your plugin and let me know if it has been solved.

#150297

That did not work 🙁

#150550

Dear Sammut,

It is working fine on my localhost. Please try to update Views to the latest version also. If it still not working, please send me credentials to access your site. I'm sending an email asking this one.

#150570

Dear Sammut,

It is working as expected, take a look at the attached images showing the steps. I can not see the problem you told me, you need to have sure that you have Business Listings created to the current user.

If it still doesn't working for you, please provide an login where I can reproduce this one.

#150579

Hi Adriano,

I sent you the login. I hope you received it. It is not the business listing, it is the "Fill in the form below to edit a current deal" under it. Thanks!

#151372

Dear Sammut,

Unfortunatelly I can not log using the test user credentials, please check it.

#151496

Sorry, i resent the credentials

#151605

Dear Sammut,

I don't know how you create the Edit link, but I replaced your with one that I created (see the attached image) which worked fine.

Please let me know if you are satisfied with my answer and if I can help you with any other questions you might have.

#151610

I have no idea how I did it different, but your does work. Thank you. I have one last question that I will post under a new question. Thank you!

#151627

Great, you are welcome!