Skip Navigation

[Resolved] Creating Woocommerce Shop Archive with block shows in a single column

This thread is resolved. Here is a description of the problem and solution.

Problem: The user has created an archive template for products but the columns were not respected.

Solution: It turns out that the WooCommerce module of GeneratePress was interfering with Toolset and Blocks styles. After disabling the module in Appearance->GeneratePress, the issue was resolved.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by MargeP6083 11 months ago.

Assigned support staff: Jamal.

Author
Posts
#1760683

I am trying to: create a shop page with list of products (full width single column)

Link to a page where the issue can be seen:

I expected to see: full width products. (created with toolset blocks)

Instead, I got a thin column of products shown here: hidden link

Documentation says use Layouts. That is no longer recommended use. I used the blocks for the layout.
In the settings, I see I have a choice to use classic or block editing. hidden link

So, I'm just wondering what is the current process for creating the WC shop page since layout is not recommended and blocks is not working well. Documentation would be helpful

Thanks!

#1761051

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello and thank you for contacting the Toolset support.

I logged in into your website and I tried to build another archive template to no avail. I suspect a CSS conflict between Toolset, WooCommerce, and probably the theme.
I, also, was not able to drag&drop blocks in the blocks editor, which let me suspect another conflict with a plugin or the theme.

To better analyze this issue, I would like to take a copy of your website for local debugging. Because I will be deactivating themes and plugins, I do not want to impact any other user of the site. Let me know if I can take a copy of the website or if I can freely deactivate plugins.

#1761081

Yes, thank you!

#1761141

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

I took a copy of your website and worked on it locally. It turns out that the WooCommerce module from GeneratePress theme is conflicting with the styles from WooCommerce and Toolset.

I was able to get the following results in my local copy by deactivating the WooCommerce module hidden link

To deactivate the theme's module go to Appearance->GeneratePress then deactivate the module, check this screenshot hidden link

Switch the archive template from the one I have created " Products Archive" to the first one you had "Products".

I am not really aware of what the theme's module provides. If you will require to activate it, we can find another solution. We'll need to reproduce the issue on our test servers before being able to escalate it to our compatibility team.

#1761143

I think there is another issue with Generatepress. I tried to create a single.php template, but it seems I am unable to. Now , none of the pages are working. Is Layouts required for Generate press because I don't see any other way to create the single.php. There is no documentation that up to date. Thanks!

#1761191

That worked great!

My issue is resolved now. Thank you!