Skip Navigation

[Resolved] Content Optimization (for Yoast SEO Premium) is blank with Toolset Types plugin

This support ticket is created 3 years, 8 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Kolkata (GMT+05:30)

Tagged: 

This topic contains 3 replies, has 2 voices.

Last updated by andrea-tommasoD 3 years, 7 months ago.

Assigned support staff: Minesh.

Author
Posts
#1224413
Yoast-premium-content-not-working-for-TOOLSET-TYPES-PRODOTTI-console.jpg
Yoast-premium-social-working-for-TOOLSET-TYPES-PRODOTTI.jpg
Yoast-premium-content-working-for-POSTS.jpg
Yoast-premium-content-not-working-for-TOOLSET-TYPES-PRODOTTI.jpg

I am trying to:
use Yoast Premium editor to edit, put title, description, synonyms, etc. in one specific Toolset Type.

Link to a page where the issue can be seen:
Any kind of Toolset Type post.
In this case, any "Prodotti".

I expected to see:
The functioning Yoast Premium SEO editor on the Content Optimization tab (see working image below).

Instead, I got:
A blank space, that I cannot edit.

About this problem:
The website where this problem is hidden link . The site is live right now, but the client is asking to don't test solutions that might crash it and to limit as much possible the downtime. I'll give you any kind of info/access/files to duplicate it for making it work locally.
I tried to create a staging enviroment but I encountered different types if problems, plus I can't really de-activate the Premium Yoast license and the Theme license.
Duplicator isn't a Valid option because of the number of images hosted on the website: it's about 5GB

Toolset is working, same goes for Yoast separated: you can see it functioning just fine in the "posts" section (Articoli in Italian).
But when I try to visualize/edit the Content Optiomization tab, it remains blank. Other tabs work fine.

I tried searching for the problem on the tickets but every response that might have been essential to the resolution had or hidden links or wasn't about this same problem, from what I understood.

The Website was running previously with the old version of toolset types (2.5 free version) and I bought a license to update it and look for solutions. Some pages are written in PHP with custom code from that version (/rivenditori , /marchi, /prodotti).
I used WP AllImport and Toolset Types Add-On BETA to transfert the website.

#1224538

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

Well - I see that there is update available for the plugin "Yoast Premium" - Can you update the plugin to latest version and check if that help you to resolve your issue.
=> hidden link

If there is no difference, please share latest " Yoast Premium SEO" plugin copy and I will try to reproduce the issue on my install or with the duplicator you shared in your initial post.

I have set the next reply to private which means only you and I have access to it.

#1224551
#1225148

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Well - thank you for sharing all required information.

I checked your issue by installing the duplicator package on my local test install and I found that it's your theme causing the issue. If I switch to the default theme 2019, the Yoast plugin features just works fine but not with your theme.

For now, it looks like a conflict with your theme and Yoast plugin. Can you please check with your theme or Yoast support and if they find that the core issue is Toolset we are happy to fix it.

Please update me as soon as you know more form Yoast or your theme support.

#1225331

My issue is resolved now. Thank you!