Skip Navigation

[Closed] Content Layout Editor destroys my content

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Nigel 4 years, 2 months ago.

Assigned support staff: Nigel.

Author
Posts
#495824

I am trying to: use the Content Layout Editor

I visited this URL: Edit page, pressed the orange button above the Edit panel

I expected to see: a way to edit the content layout of the curent page I was editing the old way

Instead, I got: a Toolset panel where only a small part of my page content was shown

I had put some text in my page using the normal Wordptess page editor. I had saved my page before pressing the orange button but when I saw most of my content was removed, I ended the Content Layout Editor. Returning to the edit page I got the choice to stop editing this page with Layouts, which I chose. Then I could chose to go back to the situation before starting the editor, which I did. Then I found most of the content on the page was gone and I had to restore it from a revision.

This is not what I had expected from this function and also not very intuitive. If a function introduced by a plugin removes content entered otherwise then this function should warn the user before performing this deletion.

I had expected pressing the orange button would bring me to a nice Toolset Layouts module where my already existing content would sit in a big container and where I could edit this content in columns, rows and other layout elements. I had not expected that this would delete my content.

Erik

#495992

Possibly related:

The page where this happened is not displayed correctly, although in the editor everything looks normal. On the front end some css does not apply anymore. This css is part of the child layout this page is assigned to. When I create a new page and assign it to this same child layout the css errors do not show.
I can provide you with more detailed information and even login to my site, but I don't post that in this half-open support system.

#496051

Nigel
Supporter

Languages: English (English ) Spanish (EspaƱol )

Timezone: Europe/London (GMT+01:00)

Screen Shot 3.png
Screen Shot 2.png
Screen Shot 1.png

Hi Erik

I walked through the same steps you describe but my experience wasn't the same.

Editing a page with some existing HTML in the content area I pressed the orange Content Layout Editor button.

That took me to the Layouts content editor, as shown in the first screenshot. It looks similar to editing Layouts previously, but I am only editing the content area for this page. I can still add rows with additional content etc., and the existing content is in a Visual Editor cell.

After saving that, when I return to the page editor I see screenshot 2, showing me that the page content is being designed with Layouts.

If I choose to stop using Layouts I'm asked what content I want, and when I choose the content from the last version before using Layouts it reverts me back to where I started, with the original content in the page editor.

* Update *

I'll leave the above intact, as it was my initial experience. But when going back into edit the page a second time and repeating the above, I did lose the initial content.

So then I repeated the steps over and over, lots of times, with variations, but couldn't get it to lose the content again. That is, I witnessed the problem once, but then couldn't reproduce it.

Are you seeing this problem every time you try using the Content Editor, or did you just notice it once?

Regarding the CSS issue, I'm not sure I follow. Are you talking about adding custom classes to cells in the child Layout? Or CSS rules you have globally added at Toolset > Layouts CSS and JS?

(If I need access to your site I can set a private reply where you can share details and only I will be able to see them.)

The topic ‘[Closed] Content Layout Editor destroys my content’ is closed to new replies.