Skip Navigation

[Resolved] Content Layout Changes when I switch language using WPML

This support ticket is created 5 years ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 10:00 – 14:00 10:00 – 14:00 10:00 – 14:00 10:00 – 14:00 10:00 – 14:00 -
- - - - - - -

Supporter timezone: Pacific/Niue (GMT-11:00)

This topic contains 3 replies, has 2 voices.

Last updated by Furlan 4 years, 12 months ago.

Assisted by: Yvette Oliveau.

Author
Posts
#1229866
2019-04-11_23-59-19.jpg
2019-04-12_01-49-58.png
2019-04-12_01-31-14.png
2019-04-12_01-33-06.png

Hi,

(1) I am experimenting certain issues in my Site (using Toolset Types - Real Estate Reference Site and WPML).
When I switch language, for instance, from English to Spanish, content is affected changing its layout. (see attached screenshots). For example, in English you won't see Post Title at top, but in Spanish translation it will.

This occurs only when there's a translation available for a specific CTP, otherwise it doesn't happen.

(2) I obtain an error message "The ancestors argument does not end with a valid post that is related for the returned post types on this View." on Search View for the following custom fields: city and state.

Any idea what is causing those issues?

Juan

#1229916

Yvette Oliveau
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Pacific/Niue (GMT-11:00)

Hello

I´ll be helping you with this. If you don´t mind, we will first address the issue of WPML and layout changes. Then, if the other problem is still existing, we will split this ticket and handle the 2nd issue on a new thread.

For the WPML issue, this is most likely due to custom fields that are missing in the translated CPT.

1. Temporary Access to your system
Please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem. The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

2. Please provide a case/example on your site where this is happening. Include the URL in your next reply.

THanks

#1231002

Yvette Oliveau
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Pacific/Niue (GMT-11:00)

Hello

You had all of your custom fields to "translate" when some of them should have been set to "copy". This resulted in different CSS being applied.

I´ve corrected the custom fields that were affecting the presence of a sidebar as well as the size of the slider and it seems that the layout is now fine.

Can you check this?

#1233639

My issue is resolved now. Thank you!

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.