Skip Navigation

[Resolved] "Contact" page map not changing with new address

This support ticket is created 4 years, 3 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 4 replies, has 3 voices.

Last updated by DavidW2160 4 years, 3 months ago.

Assigned support staff: Beda.

Author
Posts
#915446
map1.png
map2.png

I am trying to: activate the "Contact" map with an address

Link to a page where the issue can be seen: behind firewall, see screenshots

I expected to see: correct map of customer's address

Instead, I got: map of Seattle (Map1 and Map2). If I delete the address in settings >> maps I get this lat and long everytime -- {47.598081,-122.311297} which is the exact point on Google's Seattle map that is displaying. Where is this location stored? How can I change it to my customer's address?

#915613

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

First of all - After checking debug information you shared with us, I found that you are using outdated Toolset plugins such as Types, Views, Layouts etc..etc..

We always recommend to run your site with latest stable release plugin version.

*** Please make a FULL BACKUP of your database and website.***
Could you please update ALL Toolset plugins to it's latest official released version. You can download latest plugin release from your accounts page:
=> https://toolset.com/account/downloads/

If you see same issue after update - please share problem URL and access details. I would be happy to help you further.

#916195

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Well - I do not able to load the site. you told me to login using proxy - do you mean that I need to setup host files?

Could you please share exact step information how I can able to connect to your site with proxy?

I have set the next reply to private which means only you and I have access to it.

#916617

Several Software is still out of date, specially the active theme would need to be updated.

I assume you refer to the page here:
hidden link

That page has a Map in in and it displays an address.
The map is inserted with a Content Layout editor, in a Visual Editor Cell and should display the address coming from wpcf-company-address, logically from the very page (contact) as there is no ID specified).

That field, for this page, has this value saved:
{47.598081,-122.311297}

If you want a precise address as suggested by Google, then you need to ensure that the real address is used as per the Google Suggestion.
For example - I saved it as "16th Avenue, Atlantic, Seattle, Washington, USA" (following the autosuggest).
Then, when I save that, it shows it on the front end.

In the popup on the marker, you see what you hardcoded in the Map Marker:
<h3>A1 Reality</h3>
2262 Corinthian Ct,
Eugene, OR 97405, USA

That is correct so far as well.

Can you explain the issue to me so I can help you to solve it?

#916724

I didn't scroll down the contact page to the bottom "Contact Details" where the contact address was defined. All fixed now. Thanks.+