[Resolved] Checkboxes for allowing users to user "user registration" form not working

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Tagged: 

This topic contains 32 replies, has 2 voices.

Last updated by Ido Angel 4 months, 2 weeks ago.

Assigned support staff: Luo Yang.

Author
Posts
#1424453

Hey,
Under access settings for user forms, checkboxes aren't working. I'm trying to allow guests to register to the site in the frontend, but when I'm trying to click on the checkboxes in the access setting area - they just don't work.
Any idea?

Thanks!

#1425483

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Hello,

I have tried it in a fresh WordPress installation + the latest version Toolset plugins, but do not see the same problem, it works fine, see screenshot access2.JPG

Please try these:
1) clear your browser cache(or try with another browser) and test again
2) In case it is a compatibility problem, please deactivate all other plugins, and switch to wordpress default theme 2020, deactivate all custom PHP/JS code snippets, and test again

#1425715

hey Luo,

I tried to deactivate all plugins except tooset
I switched to 2020 theme
I tried in firefox instead of chorme
and...
no :\

It's as if even though I'm admin I don't have rights to check-uncheck these options. It's only is user forms, other checkboxes settings in access work ok.

thx
Ido

#1425721

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

It is abnormal, please provide your website database dump file, I need to test and debug it in my localhost, thanks
https://toolset.com/faq/provide-supporters-copy-site/

#1425725

I thought the problem was the form name was in Hebrew maybe, so I tried to create a new form in English - and now look what happened... the form editor disappeared. Both in regular and expert mode (see screen).

#1425785

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

What Hebrew form name you are using? Can you copy/paste it here? thanks

#1425875

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Thanks for the details, I can log into your website and see the problem, but you are using 32 plugins and a custom theme, I need your permission to deactivate plugins and theme, re-install Toolset plugins, please backup your website first.

#1425877

Sure - go ahead. Thanks!

#1425917

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

The problem should similar with this errata:
https://toolset.com/errata/checkboxes-in-toolset-access-forms-settings-are-not-working/

It has been resolved in previous version of Toolset Access plugin 2.8.2, but you are using latest version 2.8.2.1.

According to our workflow, I need to duplicate the same problem:
1) you can provide detail steps to duplicate it in a fresh wordpress installation,
2) Or you can provide the database dump file, you can try with othe mysql tools to make the database dump file, for example PHPmyadmin.

Private message box enabled. Thanks

#1425929

Hey,

Link to db:

hidden link

is this ok?

thx!

#1427213

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Thanks for the details, I am downloading the files, will update here if there is anything found

#1427451

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

I can duplicate the same problem with your database dump file, and have escalated it, will update here if there is any news.

#1428101

thx Luo!

#1430791

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Since there isn't detail steps to duplicate the same problem in a fresh WordPress installation, so I escalated this issue as an exception.

And due to the new year holiday, there might be some delay to get updated news from our 2nd tier supporters.

Please let me know if you need temprary workaround for it.

#1430919

Hey Luo,
I would love one, thanks.
Happy holidays!
Ido