Skip Navigation

[Resolved] Check if email not in a spam list for post form

This support ticket is created 2 years, 8 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 -
- 13:00 – 18:00 13:00 – 18:00 13:00 – 18:00 14:00 – 18:00 13:00 – 18:00 -

Supporter timezone: America/Jamaica (GMT-05:00)

Tagged: 

This topic contains 3 replies, has 2 voices.

Last updated by dmitryK-2 2 years, 8 months ago.

Assigned support staff: Shane.

Author
Posts
#1633235

Tell us what you are trying to do?
A'm looking for a solution to stop spamming in a cred | post Toolset forms which can be fulfilled with no registration (only typing emails from guests in site in it).

I've created a custom role for Users = "Spam" and periodically put some new users in it (with spammers - emails from front-end forms).

Are there any ready Toolset instrument to check & return error from front-end cred | post Toolset before save

Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site?

#1633427

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Dmitry,

Thank you for getting in touch.

If you are referring to checking if the user's email is on a spam list then no we are not able to do this. This would definitely require some custom code to check the email when the user submits it.

Secondly we have an anti spam mechanism in that we integrate with the Google Captcha to prevent spamming of the forms by bots.
https://toolset.com/documentation/user-guides/front-end-forms/protecting-forms-from-spam/

Please let me know if this was able to help you.
Thanks,
Shane

#1633429

ok, clear!

#1633431

My issue is resolved now. Thank you!