Skip Navigation

[Closed] Change domain doesn't change all old url's

This support ticket is created 7 years, 9 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 -
- 13:00 – 18:00 13:00 – 18:00 13:00 – 18:00 14:00 – 18:00 13:00 – 18:00 -

Supporter timezone: America/Jamaica (GMT-05:00)

Tagged: 

This topic contains 8 replies, has 2 voices.

Last updated by Shane 7 years, 8 months ago.

Assisted by: Shane.

Author
Posts
#428566

I am trying to: change domainname

I visited this URL: hidden link

I expected to see: A site that changed from url hidden link to hidden link

Instead, I got:

If you look into the html-code there are stil url's from views and featured images with hidden link in the url.

I already did the steps on https://toolset.com/faq/how-do-i-migrate-a-wordpress-site-from-one-domain-to-the-other/ but this did'nt solved the problem.

#428751

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Thomas,

Thank you for contacting our support forum.

I suspect that this issue being caused by static urls in the view.

Would you mind providing me with a copy of the code so I can have a look at it?

Please let me know.

Thanks,
Shane

#429378

Dear,

Which code do you want?

This is the code for the featured image:

<div style="background-image:url([wpv-post-featured-image size='full' output='url']);">

The views are added in lay-outs of wp-types.

#429818

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Thomas,

Thanks, this seems normal to me.

I need to debug and see why its giving you the old urls instead of the new ones.

Would you mind providing me with admin access to the website so that I can have a look ?

The private fields have been enabled for your next response.

Also please let me know which View/Layout I should be looking at.

Thanks,
Shane

#430346

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Thomas,

I took a look at the view and see nothing wrong also the images shows fine on the frontend . I'm not seeing any missing images.

Also i'm not able to access the Layouts to have a look. I'm getting access denied 🙁

Could you let me know what the website looks like for you because i'm able to see the images and the images has the right urls being loaded.

Thanks,
Shane

#430610
html-postergigant.jpg

Dear Shane,

The website looks good.
But only if i look into the html-code there are links off the view and featured image to an alias domain 'postergigant.be'.

I want to delete the domain alias 'postergigant.be' but that isn't possible because in the html there are referred to that 'old' domain.

#430865

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Thomas,

I'm not able to edit the layout.

I keep getting access denied, but would you mind removing the code and saving the Layout and re-adding back the code and then re-save.

Please let me know if this helps.
Thanks,
Shane

#431747

Dear,

I solved the problem for the featured image. i had to upload a new image and set that image as featured image.

I romeved the view out of the layout and put it back in but the url in the html-code of the view 'spinner_image":"hidden link' still is the wrong url with 'postergigant.be'.

Kind regards,

Thomas

#431968

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Thomas,

Not sure why this still occurs but could you try recreating the view and let me know if the urls are still pointing to the wrong url.

Thanks,
Shane

The topic ‘[Closed] Change domain doesn't change all old url's’ is closed to new replies.