Skip Navigation

[Resolved] Change author to User of specific Role

This thread is resolved. Here is a description of the problem and solution.

Problem:

The problem here is that the user created a custom author role but its not able to access the post type they want them to.

Solution:

It seems you will need to recreate this role and assign your users to this role.

What I would recommend that you do is to create a new role and then allow the role to copy the permissions of your Default author role.

Once you have done this then you can delete the previous role and it should allow you to select the new role to assign your users to.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Tagged: 

This topic contains 9 replies, has 2 voices.

Last updated by thomasB-2 1 year ago.

Assigned support staff: Shane.

Author
Posts
#1330751

Me must transfer some user genderated content from an old marketplace script.
So we create a CPT marketplace and add a access Role MarketplaceItemOwner.
Now we add the old content as admins.
So we have the in the past generated content.
And we have also the old user accesses of the MarketplaceItem Owners from the old websites.
We try now to assing the single Items to there old owner, but in the author Element from WordPress are the users with these specific role not shown?

What did we make wrong?

#1330935

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Thomas,

Thank you for getting in touch.

So the issue here is that you want to assign the items to the users who have the role "MarketplaceItemOwner" correct?

Please let me know.

Thanks,
Shane

#1331103

Hi Shane,

yes, i have 25 marketplace Items wich are converted from the old website and try to assign every item to the User who created it. All these Users have Role "MarketplaceItemOwner".
But in Author Pulldown from WordPress these users are not shown.

#1331603

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Thomas,

Thank you for the clarity.

So this could be because this author section is disabled. If you go to Toolset -> Post Types and edit your CPT. Scroll to sections to display when editing ...

From here enable "authors".

Then you can go back to your custom post and edit it and under screen options you can make the field visible.

Please let me know if this helps.

Thanks,
Shane

#1331689

Hi Shane,

the Author Checkbox was activated and the chooser for author was there. But there are only User with roles author and admin show. The authors with the with access created specific role "MarketplaceItemOwner" was not shown in these pulldown menu?

#1331841

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Thomas,

Can the users of the MarketplaceitemOwner see the post type on the backend ?

Does the user role have Access permissions to the Post type such as "Read" "Edit" and "Delete"?

If you're not sure then you can just allow me to have admin access to the site so that I can check on this for you.

Thanks,
Shane

#1332507

Hi Shane,

the MarketplaceitemOwner has acces for edit & Delete (their own) and Read. The Editing was made with Frontend Access Forms.

#1332651

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Thomas,

Thanks for the clarity, would you mind allowing me to have admin access to the site so that I can have a look at this for you ?

The private fields have been enabled for your next response.

Thanks,
Shane

#1332765

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Thomas,

It seems you will need to recreate this role and assign your users to this role.

What I would recommend that you do is to create a new role and then allow the role to copy the permissions of your Default author role.

Once you have done this then you can delete the previous role and it should allow you to select the new role to assign your users to.

Please try this and let me know if it helps.

Thanks,
Shane

#1334505

My issue is resolved now. Thank you!