[Closed] Can't update plugin – either fails or causes 500 server error

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 13 replies, has 3 voices.

Last updated by Beda 2 weeks, 6 days ago.

Assigned support staff: Beda.

Author
Posts
#1121404

I need to update both my TYPES and VIEWS plugins.

If I update TYPES, my frontend views disappear.

If I then update VIEWS, the update crashes while activating the plugin, and the site goes into a 500 server error state. I have to restore a backup of my plugins directory to fix it.

If I try to update VIEWS before updating TYPES then I get an error meesage: Update package not available. ()

Current TYPES version: 2.2.21
Current VIEWS version: 2.4.1

I've included my debug info.

I've included admin credentials for WP. Please do not try to update VIEWS after TYPES, due to it going into the 500 server error state.

#1121534

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Europe/Zurich (GMT+01:00)

You are running a previous (Free) Types version.

Please do this:
- backup your website
- remove Toolset from the Plugins folder (no data is lost)
- download the latest Toolset from here https://toolset.com/account/downloads/
- upload them to the plugins folder and activate

That should then not happen again as you would now be on the new (paid) Toolset Types installer versions.

#1121591

thanks for replying Beda.

Unfortunately the issue still persists. I deleted Types and Views via FTP, then uploaded the new versions through WP (add plugin), but the moment you activate Views, the site crashes with a 500 error.

I also tried uploading the plugins via FTP, still same issue.

#1121913

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Europe/Zurich (GMT+01:00)

OK; I see on your site, you have the free Types 2.3.3 and the Views Version 2.4.1, where an update for 2.6.4.2 lite is offered.

This is already not what is expected.

I will need a copy of this site, can you prepare this with this instructions?
https://toolset.com/faq/provide-supporters-copy-site/

I will need to analyse 2 things:
1. Why you have a lite plugin update offered with that version
2. Why you get an Error 500 on the update

Now, I am not sure why you receive Error 500 but it's usually due to an underlying error that the server log can tell.
Please ask the server admin for that log and send it with the Duplicate.

I can then pinpoint the issue (it is likely a timeout or memory issue or similar).
It does not happen locally, which makes me think another plugin intereferes

Please be sure that this as well happens when you follow the steps here and no other plugin is active:
https://toolset.com/forums/topic/cant-update-plugin-either-fails-or-causes-500-server-error/#post-1121534
that might help to resolve the issue for now.

#1121959
#1124541

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

Hi Marc

Sorry for the delay, Beda is off for a couple of days but will back tomorrow and can resume testing this.

#1125161

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Europe/Zurich (GMT+01:00)

I see the error logs are showing several issues.
The Duplicate took a while to download and deploy locally; I did disable all plugins but Toolset during the Duplication.
I got some errors on login:

ERROR: Cookies are blocked due to unexpected output. For help, please see this documentation or try the support forums.

and

( ! ) Warning: Cannot modify header information - headers already sent by (output started at .../wp-includes/class-wp-hook.php:286) in .../wp-login.php on line 423

I was not able to log in, as upon sending in the login details, more errors happened:

( ! ) Warning: Parameter 2 to __search_by_title_only() expected to be a reference, value given in .../wp-includes/class-wp-hook.php on line 286

(Repeated many times)

I removed the theme, all modified htaccess, customization from said, removed all MU Plugins,
I hen could log in, and I downloaded a fresh set of Toolset form https://toolset.com/account/downloads/ and applied them to the duplicated site.
No issue was encountered during this process.

This problem is likely not due to Toolset, but the underlying issues on the site as shown above.
Something is interfering from the Theme or other Plugins, with WordPress Itself.

I recommend to deploy this site locally and solve those issues one by one, so to later deploy them online.
That will likely solve future issues as those errors will not stop other plugins from executing anymore.

Later on the duplicate I also re-activated theme, and plugins.
I got again errors:

( ! ) Fatal error: Uncaught Error: Call to undefined function mysql_error() in .../plugins/revslider/inc_php/framework/db.class.php on line 29

Those are not related to Toolset.

#1125957

Hi Beda, thanks for your ongoing assistance.

One thing that I'm finding confusing here, is your earlier comment:

"OK; I see on your site, you have the free Types 2.3.3 and the Views Version 2.4.1, where an update for 2.6.4.2 lite is offered.

This is already not what is expected."

The versions offered in my account are:

Types 3.1.2
Views 2.6.4.2

Are these the correct ones, and as you would expect?

#1126165

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Europe/Zurich (GMT+01:00)

Yes.
However, it seems there was a problem earlier where the lite/free versions where pushed, that is what I maybe saw when I logged in.

Just remove the current plugins and replace with copies from here:
https://toolset.com/account/downloads/
No data is lost and after you have the right versions.
==> Still, I suggest to backup before you proceed.

#1131074

Hi Beda. I can't replace the replace the lite/free plugins - that was the whole point of this support thread.

I've tried deleting them, uploading via FTP, disabling all plugins, changing to a default WP theme. No matter what I do, the TYPES update stops the installed version of VIEWS from working and the VIEWS update causes a 500 error.

Can you at least supply me legacy versions of the plugins to replace the lite versions that I have? At least we can then discount that as an issue.

#1131081

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Europe/Zurich (GMT+01:00)

I am not sure why you cannot replace the lite plugin.
You have a Toolset LifeTime account, usually, you would not use the Lite versions but PRO versions as downloaded from Toolset.
Lite is only available when downloaded from WPML.

As I mentioned earlier, you have a Lite version installed right now, and the Installer is trying to push you a Lite update.

What Toolset do you want to be installed?
Lite or PRO?
To install, remove the current ones, then download EITHER from WPML (lite) OR Toolset (PRO) and re-install.

If that does not work, please remove other plugins and use a native theme and make sure your Database blog_charset is not hacked or modified to UTF-7, which is a very common issue lately in WordPress, and WILL break the update or even install of Toolset (is however not a bug in Toolset itself)
You can easily check your charset in the options database table under option name blog_charset.
It should say UTF-8.

The legacy of our plugins can be downloaded from the changelog sections of both WPML or Toolset pages (under each plugin there is a changelog link, where you find older versions)

However as stated here:
https://toolset.com/forums/topic/cant-update-plugin-either-fails-or-causes-500-server-error/#post-1125161

The update works, it is instead due to some 3rd party or other error (the error log you shared is swamped with) on the site.
I would recommend fixing those issues, as they may interfere here as well.

#1133533

Hi Beda,

Thanks again for all your on-going support.

I have checked blog_charset and that's UTF8, as it should be.

I've gone about installing the legacy updates (Pro versions) one updated version at a time, and have got the site up to the following versions, without any issue:

Types: 2.3.2
Views: 2.6.3

If I go any higher than Types 2.3.2 (which is 3.0 and above) the views no longer work on the front-end.
If I go any higher than Views 2.6.3 (which is 2.6.4 and above) I get a 500 error.

It's strange that the problems occur only after those particular update versions.

Unfortunately the client is not willing to pay for my time to look into the server errors found in the log, so I can't discount those issues.

#1134093

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Europe/Zurich (GMT+01:00)

I can try to help you on a testing site.
I cannot update the live site as obviously the risk is too high

On the test Site I will need full SFTP; PHP My Admin for the Database and Admin access to the WordPress backend.
Please remove all other plugins, install a native theme, then I will update toolset there.

If there are 3rd party errors we cannot narrow down this (locally not replicable) issue.

I activated a private reply for new access to a test site
If you have no testing ground we can offer a server (temporarily) for free where you can deploy your site and we can have a look.

#1134143

Thanks Beda,

I will make a copy of the site on the current server, under a sub-domain. Removing all other plugins - can I just delete them via FTP, or do they need to be uninstalled through WP?

Unfortunately I won't have time to do this until the weekend, but as soon as I've done it I'll post privately with the SFTP login, PHPMyAdmin and WP admin details.

#1134170

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Europe/Zurich (GMT+01:00)

Please do not install this in a subdomain of the same install (WordPress multisite).
It's fine however if you mean a subdomain of the server, that's ok, like sub.site.com

3rd party plugins may require additional steps to deactivate properly, usually however it's enough to deactivate them in Dashboard > Plugins.

The idea is just to exclude any interference from other software.

I activated a private reply so you can when ready submit me the data.

The topic ‘[Closed] Can't update plugin – either fails or causes 500 server error’ is closed to new replies.