Skip Navigation

[Resolved] Can’t remove sidebar on taxonomy archive pages

This thread is resolved. Here is a description of the problem and solution.

Problem:

The issue here is that the user wanted to remove the divi sidebar using our Content template settings for the divi theme.

Solution:

In this case it turned out to be a bug in divi and the user was able to resolve the issue with this css below.

body.tax-ort #main-content .container:before {
    content: unset;
}
 
body.tax-ort #main-content .container #left-area {
    width: 100%;
}
This support ticket is created 4 years, 1 month ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by BenjaminH2340 4 years, 1 month ago.

Assigned support staff: Shane.

Author
Posts
#1079627

I am trying to:
Create a new archive page for my custom taxonomy "Ort" without sidebar. So I was editing my wordpress archive "ort" and set "Sidebar" to "Disable" under "Theme Settings". I want the sidebar be removed only at this page. It should not effect all other pages.

Link to a page where the issue can be seen:
hidden link

I expected to see:
A fullwidth layout without sidebar

Instead, I got:
Same view with sidebar but only the sidebar is invisible. The line / divider from top to bottom is still there and the left section is not fullwidth

Additional information:
I'm using Divi

#1079718

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Benjamin,

Thank you for contacting our support forum.

Could you try using the parent theme and let me know if the issue still remains?

Thanks,
Shane

#1079722

Hello Shane,

I switched to Divi Parent Theme and set the sidebar option again to disabled for this archive.
It's still the same result. You can see it if you take a look at the link I've posted at the beginning.

#1079726

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Benjamin,

Would you mind providing me with a copy of the site so that I can debug this locally to see what the issue is ?

To provide the copy of the site please follow the instructions in the link below.

https://toolset.com/faq/provide-supporters-copy-site/

Thanks,
Shane

#1080279

Hey Shane, we meanwhile found the bug. It's a Divi CSS issue - so nothing depending from toolset. Thanks for your help!
For all other with this problem... The following little css code works finde:

body.tax-ort #main-content .container:before {
    content: unset;
}

body.tax-ort #main-content .container #left-area {
    width: 100%;
}

Because of ".tax-ort" it's only affecting my custom taxonomy called "ort".