Skip Navigation

[Resolved] Can’t delete Post Field Group

This thread is resolved. Here is a description of the problem and solution.

Problem: I'm unable to add or edit post fields.

Solution: Flush the memcache and/or remove the Memcached Redux plugin.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Christian Cox 2 years, 3 months ago.

Assigned support staff: Christian Cox.

Author
Posts
#909409

Hi, we already have two tickets with the same title, but they've both been closed! So continuing here:

So we've installed the latest version of Types, and have also tried the RC version. There's a slight improvement in that the field groups are now appearing in the list. However, when fields are added and these are assigned to a post type, these do not show up in the actual post editor.

#909455

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi, I'll be glad to help. First, please try these troubleshooting steps:
- Temporarily deactivate all plugins except Types, and activate a default theme like Twenty Seventeen. Check the post editor screen again.
- In the post editor screen where this field group is assigned, scroll to the top right corner and click "Screen Options". Look for the field group here, and make sure it is checked active.
- If the field group cannot be found in the Screen Options tab, create a new Field Group and a new custom field, then assign it to this post type. See if the new Field Group appears in the Screen Options tab and the post editor screen.

Let me know what you find out and we can go from there.

#910754

Hi Christian, thanks for your response. We have already tried all the things you suggest. Is it possible to resurrect the previous support ticket we had on this subject? That contains the history of what we've already done.

Many thanks.

#910791

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Okay I see, thank you. It is not possible to reopen either of those tickets. The first one was created on the community forum, which is now closed. The second one was closed after a 30-day waiting period where we didn't get any feedback from you, but I'll be glad to continue assisting you here. The credentials provided in the other ticket no longer work for me, I'm seeing an error that I must use a valid email address to log in. Can you provide updated credentials?

Also let me know:
- Which fields you cannot see in the post editor screen, and which post type you are checking
- If you are still unable to delete a field group, let me know which one

#913119

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you, I'm working on the staging site now and will update you shortly.

#913126

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Okay I think I see the issue. I have temporarily deactivated the Memcached Redux drop-in by renaming the file /wp-content/object-cache.php to /wp-content/object-cache.php.bak

Now I'm able to add and edit fields as expected. Can you confirm? If so, then you can ask your hosting team if there is a way to manually or periodically flush Memcached Redux object caches. Initiate a cache purge, then rename the file back to /wp-content/object-cache.php like it was originally.