[Resolved] Can not install Framework demo

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Tagged: 

This topic contains 10 replies, has 9 voices.

Last updated by nickB-8 4 years, 3 months ago.

Assigned support staff: emerson.

Author
Posts
#292142

I am trying to install Framework demo. But without success. Stuck in downloading demo content.
As site is on VPS, that I can manage, what settings should I increase?

#292242

Dear Erik,
Most issues with incomplete imports are caused by insufficient timeout settings in the server. When a timeout is reached while import is ongoing, the server returns an error like 500 internal server error. To verify if this issue is really caused by timeouts, you can check in the browser console (like Firebug) while the downloading and importing posts is still ongoing (it will return 500 internal error in AJAX response). Or you can view in server logs regarding the exact error that is returned when it get stucked while importing.

If this issue is caused by server timeouts, you might want to increase timeouts to complete this process. To do this, it depends on what type of server/PHP configuration is used.

If your server is Apache, you need to check if you have sufficient timeout assigned. Usually this is Apache 'Timeout' directive:
hidden link
We recommend to start setting at 300.

Also if your server runs on FastCGI, it has its own timeout settings. One setting that you can adjust is IPCCommTimeout for FastCGI. You can read this tip here:
http://stackoverflow.com/questions/11445432/apache-500-error-with-php-fun

PHP has its own timeout settings:
hidden link

Once all are set properly, restart your Apache server and then reset the site again. Go to Manage sites -> Reset. Then repeat the import. If its still stucked on step 2. Please provide your WordPress login details and we will check this issue directly in your test site. I have set your next reply as private so you can enter these credentials securely. Please let me know how it goes. Thanks 🙂

Cheers,
Emerson

#292268

Thank you, Emerson!

These links solved a problem with Demo installer.
Had to increase
IPCCommTimeout from default 31 to 7200

Now everything is fine.

#371935

For Nginx, I fixed this with the following:

Edit /etc/nginx/nginx.conf and add/match the following:
keepalive_timeout 125;
fastcgi_read_timeout 125;

Source: hidden link

#421011

Hello,
I have same problem. I can see solution but I have not got server I have webhosting. I tried to upgrade my webhosting, but it did not help.

What should I do? I have been using this provider. hidden link Should I use other one?

Thank you

#478363

If this can be of any help to others:
I am on shared hosting and just by adding these two lines to my wp-config.php file I have been able to install Classified:

define('WP_MEMORY_LIMIT', '256M');
define('WP_TIME_LIMIT', '1000');
#522034

Hi,

I can't download the "WooCommerce with Layouts" via the Toolset Framework installer. It is a server timeout issue but I don't know how to edit it.

I've tried on the host website (OVH). And I've tried adding in the wp-config the following lines :

"define('WP_MEMORY_LIMIT', '256M');
define('WP_TIME_LIMIT', '1000');"

Any help?:)

#548243

Hi,

I also wanted to install Classifieds with Layouts via Toolset Framework Installer, but every time I try it falls when Downloading and importing Posts and Images because of timeout error. I use webhosting so my options are limited. I have added WP_MEMORY_LIMIT and WP_TIME_LIMIT as shown above, but still not working. Is there any other possible way how to install it?

Thank you.

#554321

I contact the hosting company through chat and they change it

#554324

I contact the hosting company through chat and they change it

#596000

I changed the timeout settings as you recommend and it does get further along but stops at 160/160 and won't move onto downloading and importing views.

Can you help me please