Skip Navigation

[Resolved] blocks interface will not show

This thread is resolved. Here is a description of the problem and solution.

Problem:

Need to use Blocks editor to edit page when use Divi theme.

Solution:

it is a DIVI setting, you can try these:

Dashboard-> Divi-> Theme Options-> Builder-> Advanced, disable option "Enable Classic Editor", and save.

Relevant Documentation:

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Author
Posts
#1680025

I'm trying to use the blocks editor (Divi theme) to create a dynamic listing of a specific post type. I can use the blocks editor for "Content Templates", and I have my editing interface set to "Show only the Blocks interface" in the Toolset settings, but when I create a page using the standard editor, I only see Gutenberg. No blocks!

#1681455

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting us and I'd be happy to assist.

This can happen if the "Classic" editor is set as a default editor in the post type settings of the "Pages" post type.

Please go to WP Admin -> Toolset -> Post Types and edit "Pages" post type and select "Block" or "Per post" for the "Editor (required)" field.

I hope this helps and please let me know if you need any further assistance around this.

regards,
Waqar

#1689051

Hi Waqar,

Thanks for your reply. Unfortunately this was already set as well - I set this to "block" quite early.

I should note that I am able to use the Toolset Post Template creator, which uses the block editor.

Thanks,
Alexa

#1691035

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Hello,

Waqar is on vacation, I will take care this thread.

I have tried it with the latest version of Toolset plugins + Divi theme in a fresh WP installation, but can not see the problem as you mentioned above, please try these:

1) Make sure you are using the latest version of Toolset plugins, you can download them here:
https://toolset.com/account/downloads/

2) If the problem still persists, please provide database dump file(ZIP file) of your website, you can put the package files in your own google drive disk, share the link only, also point out the problem page URL, I need to test and debug it in my localhost, thanks
https://toolset.com/faq/provide-supporters-copy-site/

#1704637

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

The file you provided above is not valid, I get 404 error, as I mentioned above:

you can put the package files in your own google drive disk, share the link only, also point out the problem page URL

Private message box enabled again.

#1712245

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Thanks for the details, I am downloading the files, will update here if find anything

#1712249

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

I can not find the file installer.php in the package file, please provide it, you can put it into your own google drive disk, share the link only, thanks

#1712755

I've added the link to my last private message.

Best,
Alexa

#1713251

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

I can duplicate the same problem with your duplicator package, the problem persists even deactivate all Toolset plugins, and it is from DIVI theme, you can try these:
Dashboard-> Divi-> Theme Options-> Builder-> Advanced, disable option "Enable Classic Editor", and save. see screenshot divi-editor.JPG

It works fine in my localhost, see screenshot divi-editor2.JPG

#1713359

That fixed it, thanks so much!