[Resolved] Beaver Builder not working in some beta4 Content Templates

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Luo Yang 2 years, 9 months ago.

Assigned support staff: Luo Yang.

Author
Posts
#423970

I am trying to: use BB in CPT Archive Loop (A custom recipe post type with Difficulty level taxonomy), but the edited BB content is not showing up, only the Content Template fields.

It does not work with WooCommerce Single Product page neither, nor with Product Category taxonomy page (they use the same Content Template).
However, BB works with CPT Post archive pages of recipes.

It also seems that only one Content Template can be linked to a given taxonomy at a time, and I would need two (a header content template and a loop content template).
Could this be a problem? Nevertheless, I removed one of them I tried to use only the header template OR the loop template but neither worked for me.

Could you please show me a demo site where this type of integration work?

I attach a few screenshots as well.

I hope we can get around this,
thanks in advance,
Laszlo

#424050

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Dear Laszlo,

I see you have already put it into our blog:
https://toolset.com/2016/06/views-beta-beaver-builder-integration/comment-page-2/#comment-302466

And our developers have already into this problem, we need to duplicate same problem, please try this:
1) deactivate other plugins, and test again
2) if the problem still exists, please duplicate same problem in a test site, and fill below private detail box with login details and ftp access. also point out the problem page URL and view URL, we need a live website to test and debug. thanks

#424654

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Thanks for the details, checking in your website, will feedback if there is anything found.

#424673

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

I tested the credentials you provided, the WordPress access is valid, but the FTP access isn't valid, I get this error:
Command: USER toolset@zilacakemould.com
Response: 331 User toolset@zilacakemould.com OK. Password required
Command: PASS *************
Error: Connection timed out after 20 seconds of inactivity
Error: Could not connect to server

Please check it

#424778

Hi,

I checked the admin panel, the logs say you are from a restricted country, so I asked my host provider to disable whitelisting (which means that now all countries are enabled, not only from Hungarian domains).

Please try, it should work now.

#424949

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Thanks, the ftp access is valid, I am checking your test site, will feedback if there is anything found

#425020

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

I assume we are talking about the content template:
CustomCat Archive - HEADER - template
hidden link
you are going to design it with beaver-builder, as you can see, below message prevent us to do so:
Page Builder is active.
Before you can edit with Page Builder, you need to choose what type this Content Template will display.

I put it into our to-do list as a feature request, our developers will take care of it, currently, I suggest you design it without Page Builder.

#425045

Dear Lou,

could you be a bit more detailed?
What I understand is that I cannot assign two or more Content Templates to an archive/taxonomy page.

However using only the BODY template it does not show up neither.

Here, you should see green boxes, etc:
hidden link

Also, FYI, my time zone is UTC+2 right now, so we are a bit shifted, I cannot answer promptly to your early posts.

Thanks,
Laszlo

#425070

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

As I understand, in the problem URL:
hidden link
is using layout:
hidden link

There are two content templates in it:
1) CustomCat Archive - body - template
hidden link
You can edit it with "beaver-builder"

2) CustomCat Archive - HEADER - template
hidden link
You can not edit it with "beaver-builder", this is the problem,

#425075

Yes, partly.

One of the problem is that I cannot edit 2) CustomCat Archive - HEADER - template, because I cannot assign the same taxonomy to it as it is already assigned to the BODY template.
I understood that this feature is not included yet.

The OTHER (primary) problem is that even BODY is assigned to the taxonomy, here:
hidden link

I cannot see the green boxes, etc. designed by BB in the BODY template:
hidden link

It should look like something as attached.

#425346

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Thanks for the details, I put it into our to-do list, our developers will take care of it.

#458893

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Here is the feedback from our 2nd supporters:
It is expected behavior and result, if you agree, we can take it as a feature request, thanks