Skip Navigation

[Resolved] Avada’s JS Compiler is disabled with Toolset

This thread is resolved. Here is a description of the problem and solution.

Problem:
Avada's JS Compiler is disabled with Toolset

Solution:
Toolset disables the Fusion Compilers on purpose, to solve a issue related to caching .

You can find proposed solution, in this case, with the following reply:
https://toolset.com/forums/topic/avadas-js-compiler-is-disabled-with-toolset/#post-919225

Relevant Documentation:
https://toolset.com/documentation/recommended-themes/toolset-and-avada-theme-layouts-and-custom-templates-without-coding/#avadas-css-and-javascript-compilers-are-not-working-when-using-toolset

This support ticket is created 5 years, 11 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Kolkata (GMT+05:30)

This topic contains 6 replies, has 4 voices.

Last updated by gytis 5 years, 9 months ago.

Assisted by: Minesh.

Author
Posts
#918962

I am trying to: Enable the JS Compiler to speed up the site. As soon as the Toolset plugins are enabled, the JS Compiler is turned off. I understand from here: https://toolset.com/forums/topic/dynamic-css-js-not-working-on-avada-theme-when-toolset-views-is-active/ that is is a Toolset issue. Any updates on when this will be changed? Not having the compiler active seems to be adding almost 100 more requests when the page is loaded.

Link to a page where the issue can be seen: Any page in the site, including the home page.

I expected to see: Ideally, the number of requests would be closer to 102.

Instead, I got: Instead of 102 requests, I get 195.

#919167

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

Well - I asked the question to our Devs regarding this issue and what is the purpose behind the deactivating the JS compiler from avada, please hold on for further update.

#919225

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Toolset disables the Fusion Compilers on purpose, to solve a issue related to caching .

However - as you pointed out that this causes to have more request, I've escalated this issue to our next level support for further debug they will debug dig it further.

I do not have any solution for you as of now but even I do not suggest to modify the core files of view's plugin as its not something we recommend to do.

Please note that the issue is filed but there is no ETA on it.

#1087075

Any updates?

#1100245

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

You can turn Avada Fusion compilers on or off by going to the Toolset -> Settings page and scrolling to the Avada Fusion Compilers Options section.

More info:
=> https://toolset.com/documentation/recommended-themes/toolset-and-avada-theme-layouts-and-custom-templates-without-coding/#frequently-asked-questions

#1112426

I have no such option. Very much looking to fix this as well. Our site is loading over 200+ requests because of this issue.

#1117900
This ticket is now closed. If you're a Toolset client and need related help, please open a new support ticket.