Skip Navigation

[Resolved] autoloader

This thread is resolved. Here is a description of the problem and solution.

Problem:

I am trying to: The site had a "503", I granted more space, the site appeared to show up (I did not test), then after a short while I got "500" error and error-log showed that a folder "autoloader" under "....plugins/types/vendor/toolset" is totally missing leading to a fatal php error.

Now, how to re-upload it? Which plugin to deactivate from the file level, so I can login? Which toolset plugins to re-install?

Solution:

According to the debug logs you mentioned above: 500" error and error-log showed that a folder "autoloader" under "....plugins/types/vendor/toolset" is totally missing leading to a fatal php error.

It is from the Types plugin, I suggest you check these: 1) Make sure you are using the latest version of Toolset plugins, you can download them here: https://toolset.com/account/downloads/ 2) re-install the Types plugin, you can follow our document to install Types plugin manually: https://toolset.com/faq/how-to-install-and-register-toolset/#manual-installation-if-you-dont-have-types-plugin

Relevant Documentation:

https://toolset.com/faq/how-to-install-and-register-toolset/#manual-installation-if-you-dont-have-types-plugin

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will start replying to tickets in about 1.34 hours from now. Thank you for your understanding.

This topic contains 15 replies, has 2 voices.

Last updated by michaelR-12 3 years, 8 months ago.

Assigned support staff: Luo Yang.

Author
Posts
#603604

I am trying to: The site had a "503", I granted more space, the site appeared to show up (I did not test), then after a short while I got "500" error and error-log showed that a folder "autoloader" under "....plugins/types/vendor/toolset" is totally missing leading to a fatal php error.

Now, how to re-upload it? Which plugin to deactivate from the file level, so I can login? Which toolset plugins to re-install?

Or another apporach?

Link to a page where the issue can be seen: start

I expected to see: site

Instead, I got: error 500

#603669

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Dear Michael,

According to the debug logs you mentioned above:
500" error and error-log showed that a folder "autoloader" under "....plugins/types/vendor/toolset" is totally missing leading to a fatal php error.

It is from the Types plugin, I suggest you check these:
1) Make sure you are using the latest version of Toolset plugins, you can download them here:
https://toolset.com/account/downloads/
2) re-install the Types plugin, you can follow our document to install Types plugin manually:
https://toolset.com/faq/how-to-install-and-register-toolset/#manual-installation-if-you-dont-have-types-plugin
section "Manual Installation (if you don’t have Types plugin)"
3) deactivate other plugins and switch to wordpress default theme, and test again
4) Enable PHP debug mode, copy and paste the debug logs here
PHP Debugging
In case you think that Types or Views are doing something wrong (what we call a bug), you should enable PHP error logging. Again, edit your wp-config.php file and add the following:

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . 'https://cdn.toolset.com/error_log.txt');
This will produce a file called ‘error_log.txt’ in your WordPress root directory. Make sure that the web server can create and write this file. If it cannot, use an FTP program to create the file and make it writable to Apache (normally, user www-data).
https://toolset.com/documentation/user-guides/debugging-types-and-views/

#603679

Hi Luo,

thank you, seems straightforward, but I fear I get into more issues and also I want it done fast.
Therefore can you be so kind to look yourself and path the way and hopefully solve it, when I give you the credentials to the site.
hidden link
webmaster
****
I hope this works out,
Best, Michael

#603692

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

I have modified your post to hide the password, it is not safe to post it publicly.

And I tried the credentials you provided above, I can only see 500 errors:
This page isn’t working
hidden link is currently unable to handle this request.
HTTP ERROR 500

So I can not login your website, and can not do any debug in your website, if you still need I check in your website, please provide the credentials and FTP access in below private detail box, I need to test and debug it in a live website.

And since it is a server problem or compatibility problem, there isn't any ETA to fix it.

#603717

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

I tried the FTP access you provided
https://toolset.com/forums/topic/autoloader/#post-603702
but get this error:
Command: USER stiftung
Response: 331 User stiftung OK. Password required
Command: PASS *****************
Response: 530 Login authentication failed
Error: Critical error: Could not connect to server

Please check it, make sure it is valid.

For your another website, if it is the same problem, we can handle both problem in this same thread, if not, please create new thread for the new question.

#603750

I created for you:
FTP-username: luang@stiftung-fuer-helfer.de
FTP-Server: hidden link
Port for FTP & explic. FTPS: 21
pass: *******
I hope it helps ?

#603779

Pls PM me to get new pass 🙂
PS: Only you can make a post private?

#603965

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Please don't share the credentials publicly, it is not safe. you can update your private post:
https://toolset.com/forums/topic/autoloader/#post-603702
Or provide new credentials in below private detail box.

#604167

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Thanks for the details, since you have marked this thread as resolved, I have reopened this thread and checking in your website, will feedback if there is anything found

#604171

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

The FTP access you provided is not valid, I can only see an empty folder, so it is not possible to debug the problem,
https://toolset.com/forums/topic/autoloader/#post-604017

Please make sure the FTP access is valid for the website you mentioned above:
hidden link

Then update this thread. thanks

#604330

WE should have used cpanel from the start.

you know the domain
the user: stiftung
the pass: is it private???

it works, sure. Please do it today ?

Michel

#604596

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

As I mentioned above, it seems to be a server/compatibility problem of your website, so there isn't any ETA to fix it. see our support policy:
https://toolset.com/toolset-support-policy/

And you did not provide a valid FTP access, so I can not debug in your website, as I mentioned above, you can simply update the your private post with the new FTP access password:
https://toolset.com/forums/topic/autoloader/#post-603702
https://toolset.com/forums/topic/autoloader/#post-604017

And I enabled the private message box again, please provide a valid FTP access, thanks

#604636

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

As I mentioned above the FTP access you provided are not valid, I have enabled the private message for three times, but you still did not provide a valid FTP access:
https://toolset.com/forums/topic/autoloader/#post-603702
https://toolset.com/forums/topic/autoloader/#post-604017
https://toolset.com/forums/topic/autoloader/#post-604625

If you need to send the CPANEL credentials, OK, I enabled the private message box again, please provide a valid CPANEL credentials, thanks

#604668

I did yesterday provide cpanel cred. in old prvate message.
I did once more 2 minutes ago.
Michael

#604670

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Thanks for the details, the cPanel password is valid, and I did below modification in your website:
1) rename the "wp-content" folder to "wp-content-bak"
2) Login your website,
Dashboard-> Plugins
Dashboard-> Themes
Just open above pages, it will disable all plugins
3) restore back the "wp-content" folder name
4) Dashboard-> Plugins,
delete the Types plugin, since there are broken file in it, and install the Types plugin again, please test it again:
hidden link

Your website is back, and Types plugin works fine in your website.
You will need to activate other plugins one by one, if there is other compatibility problem, please create new thread for the new question, that will help other users to find the answers.