Skip Navigation

[Resolved] Archive view destroyed since latest update

This thread is resolved. Here is a description of the problem and solution.

Problem: Archive view destroyed since latest update possible conflict with autoptimize plugin

Solution: You should try to exclude the Javascript file toolset-common-es-frontend.js and add it to your autoptimize exclude script list or You can find the proposed solution in this case with the following reply: => https://toolset.com/forums/topic/archive-view-destroyed-since-latest-update/#post-1873081

Relevant Documentation: - https://toolset.com/faq/how-to-use-optimization-plugins-with-toolset/

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by lindsayH 10 months, 1 week ago.

Assigned support staff: Minesh.

Author
Posts
#1871599
backend.png
frontend.png

My blog page isn't looking like it did before update.

I had two columns and the spacing of course was much better. More like I still see it in the backend. See images.

hidden link

#1872793

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

I checked the debug information you shared and I found that you are using the latest Toolset plugins so there must be something going wrong or possible conflict between your theme or other third-party plugins your are using.

In order to minimize the cause of the issue:
Could you please try to resolve your issue by deactivating all third-party plugins as well as the default theme to check for any possible conflicts with any of the plugins or themes? - Do you see any difference? If no:
- I will require access details to your site so check whats going wrong with your setup.

*** Please make a FULL BACKUP of your database and website.***
I would also eventually need to request temporary access (WP-Admin and FTP) to your site. Preferably to a test site where the problem has been replicated if possible in order to be of better help and check if some configurations might need to be changed.

I have set the next reply to private which means only you and I have access to it.

#1872961

Ah ha, it's autoptimize. Is there new JS that should be excluded using the latest Toolset Types update (it's something new as was fine before).

I've already followed the recommendations here: https://toolset.com/faq/how-to-use-optimization-plugins-with-toolset/ (at initial setup - not just now).

Thank you so much for your help.

#1872969

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

What if you try to exclude one more JS file: toolset-common-es-frontend.js and add it to your autoptimize exclude script list?

#1873081

Yes, I found that worked. Thank you.

As did the below in functions.php to stop issue on a specific page\pages (if it helps anyone else).

// Disable autoptimize on all pages with the words "visit-us" or "news" in the URL
add_filter('autoptimize_filter_noptimize','ninja_noptimize',10,0);
function ninja_noptimize() {
	if (strpos($_SERVER['REQUEST_URI'],'visit-us')!==false || strpos($_SERVER['REQUEST_URI'],'news')!==false) {
		return true;
	} else {
		return false;
	}
}