[Resolved] An error when creating a relationship

This thread is resolved. Here is a description of the problem and solution.

Problem: When trying to create a Post Relationship with Toolset Types, I receive an error at the end of the wizard: An error when creating a relationship "relationship name": No relationship with slug "relationship-slug" was found."

Solution: It is possible that your database for unknown reasons did not get the required Database tables added that are required by Types for this to work. Please contact our support and refer to this ticket, if you suspect this is the case.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 19 replies, has 2 voices.

Last updated by bahadirM4302 1 month, 3 weeks ago.

Assigned support staff: Beda.

Author
Posts
#1452655

Hi,
I am trying to build a post relationship, i completed all steps as mentioned this page and the video https://toolset.com/documentation/post-relationships/how-to-set-up-post-relationships-using-toolset/. But i got an error message on summary step of "relationship wizard". Message is: "An error when creating a relationship "İzlenimler Sayfalar": No relationship with slug "izlenim-sayfa" was found."
how can i solve this problem?

thank you.

#1452773

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

1. Please ensure you have Toolset Post Types registered
2. Head to Toolset > Relationships and add new relationships between those

That should work without any error, the issue you see should be due to eventually some corruption of the just created relationship.

When you head to Toolset > Relationships do you see any there?
Can you delete it? If you have no content associated with it yet, it's safe to delete it

Then recreate it, does that work?
If not, please send me a copy of that site using https://toolset.com/faq/provide-supporters-copy-site/ as a how-to base.

I can then check on that duplicate what is happening.

#1452987

Hi,

Yes, Toolset Post Types is registered.
When i look at the Toolset > Relationships there is not any relationship.
But there are 7 different Intermediary Posts button on wordpress admin sidebar and also there are maybe 20+ new intermediary post type (these are all created by me when i tried to create a relationship) in post types page, i can not delete them. When i click the post types edit button, at he bottom of the page there is a warning as "A critical error has occurred on your website. Please check your site administrator email inbox for instructions."

according to this e-mail;

page with the problem:
hidden link

problem details:
/home/kultaltc/public_html/wp-content/plugins/types/application/controllers/page/extension/edit_post_type.php dosyasının 143 satırında E_ERROR tipinde bir hata oluştu. Hata iletisi: Uncaught Error: Call to a member function get_slug() on null in /home/kultaltc/public_html/wp-content/plugins/types/application/controllers/page/extension/edit_post_type.php:143
Stack trace:
#0 /home/kultaltc/public_html/wp-admin/includes/template.php(1343): Types_Page_Extension_Edit_Post_Type->metabox_relationships(NULL, Array)
#1 /home/kultaltc/public_html/wp-content/plugins/types/vendor/toolset/types/admin.php(1784): do_meta_boxes(Object(WP_Screen), 'normal', NULL)
#2 /home/kultaltc/public_html/wp-content/plugins/types/vendor/toolset/types/admin.php(667): wpcf_admin_screen('toolset_page_wp...', '

I built duplicater plugin but i couldn't download the archive file. Everytime i try it stops at 628 KB of 393 MB. So if is is ok for you i want to share my admin credentials?

Thank you for your help.

#1456533

Hi,

Is there any solution for my problem?

Thank you.

#1456801

hi, you can find related files in below link.
hidden link

thank you.

#1457605

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

I've confirmed the issue on your site, and seen it's the same issue as described many times as below:
https://toolset.com/forums/topic/fatal-error-on-types-2-3-b1/
https://toolset.com/forums/topic/when-trying-to-create-a-relationship-i-get-an-error/
https://toolset.com/forums/topic/views-rc-certain-views-no-return-no-items/
https://toolset.com/forums/topic/error-creating-a-relationship/
https://toolset.com/forums/topic/error-creating-relationship/

All those tickets were mostly solved by upgrading SQL or allowing it to create database tables, or by updating Types.
However, it seems this did not resolve anything in your case, which I am analysing now, in order to update you with a resolution or express-report it to the developers.

#1457837

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

The error is due to a missing database table (toolset_relationships)
It is possible adding that, manually, but it will not show the relationships you created until now, instead, it'll just allow you to create new functioning relationships.

You will still not be able to delete the extra intermediary posts, but would be able to add relations and posts in relations.

However, I need to know why the table is missing.
Theoretically, this could happen when something stops Toolset from writing database tables (MySQL version, or other things).
However there should be warnings, did you ever have warnings and dismissed them, related to database tables?

Can you replicate this issue on other sites or a copy of that site?
It should not be easily replicable, as I could not unless manually tampering with the Database, provoke the toolset_relationships table to disappear.
Do you have steps on how you reached this problem?
They would be helpful to us.

I will try to prepare a full solution inclusive the removal of the existing intermediate posts, as soon as possible, to apply to your site, however it would be great to know how the issue was produced in the first place.

#1471665

Hi Beda,

Sorry for late response i was ill for a while.

No, i didn't get any warning. I've created almost 20+ post relationships that day. if there was a warning i am sure i could see it. The only warning I received is the warning I mentioned in message #1452987. But this warning doesn't show up on top of the page or in a pop up. I can only see this warning at the bottom of the "Edit Post Type" pages for "Intermediary Posts".

I am sorry but i can not replicate this issue. I don't have any other site working with types toolset also i don't know how to work with copy of the site. If it is really necessary i can replicate this on kultalt.com and can record all process. But as i mentioned before there wasn't any warning.

How i reached this problem: i just completed all steps as mentioned this page and the video https://toolset.com/documentation/post-relationships/how-to-set-up-post-relationships-using-toolset/. Everything went well. there was't any warning or problem. But there wasn't any created relationships at the end. But also there wasn't any post relationship. So I've tried all the options (for example i've created: one to one, one to many and many to many relationships. ) on documentation video to find the correct combination and again there wasn't any post relationship.

P.S. We may delete all the Post Relationships (if there is any on back-end) and Intermediary Posts. It is ok for me.

Thank you.

#1472477

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

OK, this means we could attempt to fix the database manually.

I can help with that.

Please acknowledge that any relationship created will be removed.
You did not yet connect any posts in the backend, right? You just created those relationships, which then resulted in the failure described by you, where the Plugin that did not create them.

We can, in this case, fix the database manually, by adding the missing table.
For that, I need access to the Database (PHP my Admin or similar), and you would need to perform a full back up of the website and the database.
Then, I will upload an empty version of the missing table, which should fix the issue as in you'll be able to create working relationships later.

This is ONLY good as a solution if you have no related posts yet. I assume you do not have any because of the relationships never being created in the first place.

There will remain another problem which is the intermediary post types.
We can't delete them in the Admin, and for that, I'll need some help from our developers, as those are stored in the options table
However, they should not stop us from fixing the database and create new relationships.

Can you provide access to the site, the database, and a backup of the database (most important)?
I've enabled private reply forms.

#1474567

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

Hello, I have a fix both for the missing table (which I can add manually) and for the Orphan posts.
But it needs:

1. A valid backup of the Database (SQL)
2. A valid backup of the WordPress instal (FTP)
3. Access the Database (PHP myAdmin or similar)
4. Access to the theme's functions.php file to add code, or add files with code (I need to add a small snippet for once)

We can then fix this directly on the live site.

#1476287

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

Thank you
As mentioned in https://toolset.com/forums/topic/an-error-when-creating-a-relationship/#post-1474567, I need access to the database as well.

Also, I see you are using outdated Toolset, please update them first, if possible.
I also notice this site uses another database prefix than I had in the https://toolset.com/forums/topic/an-error-when-creating-a-relationship/#post-1456801 package. Is this the same site?

I will probably better first grab a fresh copy of this site, locally test our solution, then do the same on your site.

Hence if you would not oppose, we would need a duplicate of the site as it's now.
I can do that, using the Duplicator Plugin.

I will still need to have access to your live Database, to add the database table which is missing.
Can you provide that in the next private reply, along with either a duplicator of the current site or permission to take one, so I can ensure we work on the same thing?

#1476291

Beda hi,

I have one question. If i change/update the wordpress template or update the wordpress version what will happen? Will this solution be a permanent solution? If it is not how we can make this solution permanent?

Thank you so much.

#1476301

hi,

please can you open a private reply?

thank you,

#1476323

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

#1476803

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

I've fixed the missing database table, so theoretically you can already add new relationships, BUT please wait.
I couldn't delete the orphan post types for some reason.

I am asking my 3rd tier to help me here, please stand by.