Skip Navigation

[Closed] AMP validation errors due to div tag and script added before !doctype HTML

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Hong_Kong (GMT+08:00)

This topic contains 18 replies, has 2 voices.

Last updated by Luo Yang 1 year, 4 months ago.

Assigned support staff: Luo Yang.

Author
Posts
#2162373

The staging environment wasn't working because you commented out server settings in the wp-config file. I uncommented them and now it loads.

#2162537

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

amp.JPG

I have tried these in your website:
1) Deactivate all other plugins(Except Toolset + Woocommerce + AMP plugin), rename the /wp-content/mu-plugins/ to /wp-content/mu-plugins-bak/
2) Switch to parent Astra theme
3) Since you are using old version of AMP plugin, so I have tried to install the latest version of AMP plugin in your website, but get below error message:
Installation failed: Could not copy file. accelerated-mobile-pages/accelerated-moblie-pages.php
See my screenshot amp.JPG

Your webserver is abnormal, Can you install the latest version of AMP plugin 1.0.77.22 in your website?
https://wordpress.org/plugins/accelerated-mobile-pages/

#2169319

Hi Luo

Sorry for the delay.

As you noted, there was a problem with that particular environment (nothing could be updated or uploaded).

WP Engine reset the environment and copied over the production environment.

But a more pressing - unrelated - problem arose today after updating Astra parts of content created by Types and Blocks are now missing.

I've raised a support ticket with Brainstorm Force and will let you know after they have resolved that issue before we revisit this one.

Thanks

#2169561

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

I have marked this thread as "Waiting for feedback" status, please update here when you need more assistance for it.

The topic ‘[Closed] AMP validation errors due to div tag and script added before !doctype HTML’ is closed to new replies.