Skip Navigation

[Resolved] all links to external sites formed with https:// protocol now site SSL

This thread is resolved. Here is a description of the problem and solution.

Problem:

Site recently converted to use SSL. External links from a page template all use https:// protocol even though template changed to use universal // prefix (it was previously http://).

Solution:

The Non-protocol URL is based on your current website, for example: https://www.worcestershireopenstudios.org/artist/cherrie-mansfield-2/ this page is using SSL Protocol.

I suggest you try these: 1) If the URLs are all in your website, use the non-protocol URL. Then it will be adjusted according to your website settings.

2) If the URLs are linked to outside of your website, don't use it, since you can not control other website.

Relevant Documentation:

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will start replying to tickets in about 2.12 hours from now. Thank you for your understanding.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Luo Yang 3 years, 3 months ago.

Assigned support staff: Luo Yang.

Author
Posts
#920933
Screen Shot 2018-07-04 at 17.21.40.jpg

Site recently converted to use SSL. External links from a page template all use https:// protocol even though template changed to use universal // prefix (it was previously hidden link).

This is causing an issue with external non SSL sites throwing a browser warning about being insecure. Example page with link:
hidden link

content template code:

[wpv-conditional if="( $(wpcf-website) ne '' )"]<p><a href="//[types field="website" id="" raw="true"][/types]" target="_blank">[types field="website" id="" raw="true"][/types]</a><br/>[wpv-conditional if="( $(wpcf-website) ne '' )"]<a href="//[types field="website2" id="" raw="true"][/types]" target="_blank">[types field="website2" id="" raw="true"][/types]</a>[/wpv-conditional]<br/>[wpv-conditional if="( $(wpcf-website) ne '' )"]<a href="//[types field="website3" id="" raw="true"][/types]" target="_blank">[types field="website3" id="" raw="true"][/types]</a>[/wpv-conditional]</p>[/wpv-conditional]

#921129

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Hello,

The Non-protocol URL is based on your current website, for example:
hidden link
this page is using SSL Protocol, so it will produce SSL link in below URL

<a href="//www.cherriemansfield.com" target="_blank">www.cherriemansfield.com</a>

If you want above codes link to http Protocol, you will need to add it manually, for example:

<a href="<em><u>hidden link</u></em>" target="_blank">www.cherriemansfield.com</a>
#921139

Thanks Luo Yang. That seems to work ok now but I was getting the 'half secure' padlock on these pages on the site after switching to SSL, and after changing the template to use non-protocol references that solved it.

So can I just confirm please, the non-protocol URL will always take the protocol of the site itself, and do you have any advice, or could you point me towards something which explains best practice for use going forward? I understood that it was a universal way of coding to cope with either protocol but it seems that only applies to the site itself?

Thanks, Richard

#921162

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Yes, you are right, the non-protocol URL will always take the protocol of the site itself.

I suggest you try these:
1) If the URLs are all in your website, use the non-protocol URL.
Then it will be adjusted according to your website settings.

2) If the URLs are linked to outside of your website, don't use it, since you can not control other website.

#921165

Great, thanks for your help.

#921480

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

You are welcome