Skip Navigation

[Resolved] After Download of Toolset Installer for embedded there are several folders but

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by jonathanU 6 years, 2 months ago.

Assigned support staff: Shane.

Author
Posts
#315203

I am trying to: Download the Toolset Installer for Embedded Themes

I visited this URL: https://toolset.com/account/embedded-toolset/

I expected to see: a folder "installer", including "loader.php" and some other files and folder like res, includes... (as seen on this screenshot: hidden link)

Instead, I got: a folder with a reps.xml and many subfolders named "branches", "refactoring 2014", "tags" and "trunk", some of them with many other subfolders. They seem to contain different installer versions and there are many loader.php files...
When installing the embedded theme wordpress therefore does not find the "loader.php" (there is none in the folder "installer" but several in the mentioned subfolders...)

Thanks for your help!

#315469

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Jonathan,

Thanks for contacting our support forum.

In order to get the installer for your theme you need to generate a theme key by going to the link below.
https://toolset.com/account/embedded-toolset/#theme-keys

Once you have generated your theme key select "Integration Steps" from the tab.

Scroll down to the "Select Toolset components and download Installer" section and select the components that your plugin needs and then click "Download Toolset installer"

Please let me know if this helps.

Thanks

#315549
i get.png
i expected.png

Hi Shane,

Thanks for reply.

I followed the steps as you described.

But as I mentioned above, what i get in result is a package (folder name: installer), that contains several subfolders (branches, refactoring2014, tags, trunk) which contain similar content. It seem as if the Installer comes in different versions for different purposes or something like that (see the attached screenshot).

I expected to see ONE folder that contains the necessary files like loads.php etc. in the first level plus the necessary folders like "includes" etc. as I see it in your documentation (https://toolset.com/documentation/embedded-toolset/building-and-distributing-toolset-based-themes/). See the attached screenshot from your doc.

Thank you.

#315571

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Screen Shot 2015-07-07 at 2.03.51 PM.png
Screen Shot 2015-07-07 at 2.03.37 PM.png

Hi Jonathan,

Thanks for the screenshot.

I'm not sure what is happening with this as when I downloaded the installer I only got the necessary files. See Screenshot.

Also just to confirm, please ensure that your download page looks similar to the one I have below. Also delete any installer folder you currently have and try redownloading.

Thanks

#317171

Hi Shane,

I tried downloading the installer the other day again. Worked like a charm.
I have no idea what went wrong the first time.

Thanks