Skip Navigation

[Resolved] Add to cart message not displaying consistently

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by emilyT 1 year, 7 months ago.

Assigned support staff: Christian Cox.

Author
Posts
#575315
03-with-nothing-in-basket.png
02-with-item-in-basket.png
01-added-to-basket.png

I'm wanting to use WooCommerce Views on a website I'm building, but I'm having an issue with the message that appears when you add something to the cart. I'll talk you through it:

I've got a test site running here, I'll give you a link that takes you directly to the product page: hidden link

The product page is using WooCommerce Views and I've stripped it right down to focus on the issue. The content template is this:

[wpv-add-to-cart-message]
<h1>[wpv-post-title]</h1>
[wpv-woo-buy-options add_to_cart_text='Reserve / Get a Quote']

There are two things which need to be selected before adding something to the cart. These are added using WooCommerce Product Add-ons (https://woocommerce.com/products/product-add-ons/).

This is what I'm finding:

1. If I select the two options the item is added to my basket and I get the success message (see the first screenshot with the blue message across the top of the screen).

2. If I've already got something in my basket and try to add this same product but without selecting the two options, I get the error message letting me know that these fields are required (see the second screenshot with the red message at the top of the screen).

3. However, if I've got nothing in my basket and I try to add the product without making the selections I don't get any message at all (third screenshot with no message). This is the issue.

I'm using the Twenty Seventeen theme so that I can eliminate it being an issue specific to the custom theme that I'm building. I've tried switching to use the WooCommerce Plugin Default Template rather than the WooCommerce Views single product template - if I do that then I don't have the issue with the error message not appearing. This is leading me to think that it's an issue with how I'm using the WooCommerce Views plugin. Have I missed adding something to the content template that would make the error message work more consistently?

#575401

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi, it looks like a conflict with this Product Add On. I don't think you're using WooCommerce Views incorrectly, I think that the way our error message shortcode works isn't fully compatible with this add-on. In order to confirm that, I'll need to create a clone of your site and run a few tests locally where I can monitor the server traffic. If that's okay with you, please provide login credentials here and I will install Duplicator and create a site clone.

#575475

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Okay I'm able to reproduce this issue on a clean site installation, starting from scratch, and adding the same template code you're using. So I think the next step is for me to escalate this to our 2nd tier support team for further investigation. Please standby and I will update you when I have some more information to share.

#575599

Thanks Christian

#591721

Hi Christian

It's a little while since I've had an update to this issue. Could you let me know where you are with it please?

Best wishes, Emily

#591760

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi, unfortunately I do not have much more information to share right now. I can see that our 2nd tier support team has escalated this to our WooCommerce Views developers as a compatibility issue with the Add-ons plugin, however I do not see that a resolution is available just yet. I'll keep you posted if I hear any new developments.

#592503

Thanks Christian, I'll hope to hear more from you soon.
Best wishes, Emily

#611477

Hi Christian

I just wanted to do a quick follow-up regarding this issue. Can you let me know if there's been any progress please? We're keen to move our project along, but it is a bit of a problem that the messages aren't consistently displaying.

Many thanks, Emily

#611491

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I apologize for the delay, but I don't have anything new to share. I believe the upcoming M2M features are taking top priority for our developers right now, so some compatibility tasks have been delayed. I'll let you know if I hear anything new.

#1401145

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hello, I've been going through some old tickets and I ran some tests with updated versions of all the software involved here. Now when I try to add a product without selecting a required radio button, a warning appears. I'm not able to add the item to my cart until I have selected one of the radio fields. I'm not exactly sure when this behavior started, but it does seem to be fixed in the latest versions:
Product Add-Ons 3.0.20
WooCommerce 3.8.1
Types 3.3.7
Views 2.9.4
WC Views 2.7.11

I tested with Twenty Twenty and Twenty Seventeen, both with the same success. Can you confirm this has been resolved?

#1402131

Hi Christian

I do believe this issue has resolved itself. Fingers crossed!

Cheers, Emily