Skip Navigation

[Resolved] Add to Cart Button Incorrectly Only Adding Qty 1

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by aaronM-9 1 year, 4 months ago.

Assigned support staff: Waqar.

Author
Posts
#1609087

I have a view that shows WooCommerce products and am using the following shortcode to display an add to cart button:

[wpv-woo-buy-or-select add_to_cart_text="Add" show_quantity_in_button="yes"]

When entering qty 15 and clicking the button it only shows 1 unit in the cart upon checkout. When adding the item directly from the single product details page, it does allow you to add 15. I can't figure out why it's only adding 1 from the View. Inventory is not managed and everything is listed as in stock. Thanks for any help. This is causing orders to be wrong on the website!

- Aaron

#1610203

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Aaron,

Thank you for contacting us and I'd be happy to assist.

This issue has been reported already and it happens when WooCommerce's AJAX add to cart feature is enabled:
https://toolset.com/errata/impossible-to-add-more-than-one-item-to-cart-on-the-shop-page-if-styled-with-woocommerce-views/

I'll update you through this ticket, once a fix for this has been released and for now you can include the script from the above link in your view, as a quick workaround.

regards,
Waqar

#1610705

Thanks - that did the trick. Should I leave the ticket open?

- Aaron

#1610731

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks for the update and glad that it worked.

You're welcome to mark this ticket as resolved and since this ticket is already in my follow-up list for this particular issue, I'll let you know once a fix is out.

#1610737

My issue is resolved now. Thank you!