Skip Navigation

[Resolved] Activating Toolset Access crashes the site

This thread is resolved. Here is a description of the problem and solution.

Problem: The user site crashes after activating Toolset Access.

Solution: This is an issue that happened when: - Using Avada theme. - Using WPML. - Managing the default post types(posts, pages) with Toolset Access. The issue was resolved in Types 3.3.11 and Access 2.8.6

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 57 replies, has 2 voices.

Last updated by simonM-5 1 year, 5 months ago.

Assigned support staff: Jamal.

Author
Posts
#1596797

Hi Support

When activating Toolset Access on our site it is crashing. The automatic updating of all Toolset plugins is also failing since yesterday with "Download failed. (Forbidden)" error message.

Yesterday supporter Jamal installed Toolset Access on our site manually by installing the plugin WP File Manager and since then the site is crashing constantly. The only way I can get the site to load is to deactivate Toolset Access.

I am presuming that both errors are related.

This is the error occurring when Toolset Access is active and you try to load the home page from the front end. The issue might be somehow linked to WooCommerce and Toolset working together as that's what I was working on when all the problems started, maybe that info helps.

Thanks and regards
Simon

__________________________________________________________________

There has been a critical error on your website.

Learn more about debugging in WordPress.

WordPress database error: [Table 'kledbdev.a' doesn't exist]
SELECT a.action_id FROM a WHERE a.hook='action_scheduler/migration_hook' AND a.status='in-progress' ORDER BY scheduled_date_gmt DESC LIMIT 1

WordPress database error: [Table 'kledbdev.a' doesn't exist]
SELECT a.action_id FROM a WHERE a.hook='action_scheduler/migration_hook' AND a.status='pending' ORDER BY scheduled_date_gmt ASC LIMIT 1

WordPress database error: [Table 'kledbdev.a' doesn't exist]
SELECT a.action_id FROM a WHERE a.hook='action_scheduler/migration_hook' AND a.status='in-progress' ORDER BY scheduled_date_gmt DESC LIMIT 1

WordPress database error: [Table 'kledbdev.a' doesn't exist]
SELECT a.action_id FROM a WHERE a.hook='action_scheduler/migration_hook' AND a.status='pending' ORDER BY scheduled_date_gmt ASC LIMIT 1

WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'WHERE slug='action-scheduler-migration'' at line 1]
SELECT group_id FROM WHERE slug='action-scheduler-migration'

WordPress database error: [Incorrect table name '']
SHOW FULL COLUMNS FROM ``

#1597699

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello and thank you for contacting the Toolset support.

The errors seem to be related to database migration, usually required after WordPress or plugin update. WooCommerce do make database migration on update if needed.

Do these errors disappear if Toolset Access is deactivated? If yes, please check if product permissions are managed by Toolset Access at Toolset->Access Control->Post Types(tab).

We may need to take a copy of your website to further analyze these errors locally. If you are ok, please let me know and provide credentials access, I'll try to take a Duplicator or UpdraftPlus copy and debug it locally. Your next reply will be private to let you share credentials safely. ** Make a database backup before sharing credentials. **

#1597743
#1597785

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Thank you Simon for your feedback and the access credentials.

Unfortunately, I was not able to create a new Duplicator package and I was not able to download today's package too. Can you share a duplicator copy on sharing service like Google Drive or DropBox? Your next reply will be private to share the download link safely.

#1597883

Hi Jamal

I think my host changed some setting. I had to enable Client Side kickoff to get the package to be created successfully.

If you log in again now, you should be able to download the package.

Kind regards
Simon

#1597937

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Thank you Simon,

I was able to download a Duplicator copy, but could not build it locally, these are the errors I am having hidden link
I could not find anything online about these errors and some of my colleagues did never see it before. Maybe that's something new in a recent Duplicator Pro release.

Maybe we should try with a different configuration for Duplicator or UpdraftPlus plugin instead.

In the meantime, I would like to confirm if the issue is still happening? I tried to check it but the ftp access are not working for me.

#1597961

HI Jamal

Hmm, I don't know why Dup Pro is acting up either. As you can see it was working fine for several days in a row and started hiccupping yesterday.

I apologise, I deleted the FTP account that I had setup previously for Toolset Support, I have set it up again with the given credentials, so you should be able to log in again now.

In the meantime I told Toolset Access to Use the default WordPress read permissions, however this is something I would like to have working as I find Toolset Access very useful indeed, and don't want to start another method for the security for Woo.

After making the changes to Toolset Access regarding Products, the issue is still present.

Thanks and regards
Simon

#1597973

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Thank you! Indeed the FTP is working for me. But I could not find any logs file.

I suppose I'll need a copy and check locally. We may use UpdraftPlus for this, as Duplicator did not build locally for me.

I will also need to know which Access settings you have used that contribute to generate the problem. Once I could reproduce the problem locally, I can analyze it or escalate it to our 2nd Tier if I get stuck.

#1597987

HI Jamal

I've never used UpdraftPlus before. If this is a free plugin that allows you do duplicate our site so you can work on it locally, you have my permission to install it for the purposes of this support ticket.

It really was the Products settings which I changed recently (yesterday). All other settings have been working reliably with Access.

Please let me know if I can assist you further.

Kind regards
Simon

#1599059
#1599071

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

I Installed UpdraftPlus and tried to take a copy of your website but it seems stuck for more than an hour. Check this screenshot hidden link

Please follow the instructions on my private reply(April 24, 2020 at 11:40 am) to migrate your website on our platform. Check this screenshot hidden link

Once the migration is finished, please activate Toolset Access and configure access to products in order to reproduce the issue. If we reproduce the error, I can investigate why is this happening.

#1599179
#1599181

PS Please hide these links from the public

#1599273

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

I recovered the migrated site by deactivating temporarily all plugins, then I reactivated a minimal set of plugins to check.

Can you please try to reproduce the issue? Let me know which settings you will be using.

#1599299

Hi Jamal

Unfortunately I cannot log in to the migrated site - how did you manage to get in??

I'm getting the following error messages:

Fatal error: Uncaught Error: Class 'OTGS\Toolset\Access\Controllers\CustomErrors' not found in /mnt/BLOCKSTORAGE/home/219772.cloudwaysapps.com/snkvzuwbjs/public_html/wp-content/plugins/types-access/application/models/wpml_settings.php:400 Stack trace: #0 /mnt/BLOCKSTORAGE/home/219772.cloudwaysapps.com/snkvzuwbjs/public_html/wp-includes/class-wp-hook.php(287): OTGS\Toolset\Access\Models\WPMLSettings->check_language_edit_permissions(Array, Array) #1 /mnt/BLOCKSTORAGE/home/219772.cloudwaysapps.com/snkvzuwbjs/public_html/wp-includes/plugin.php(206): WP_Hook->apply_filters(Array, Array) #2 /mnt/BLOCKSTORAGE/home/219772.cloudwaysapps.com/snkvzuwbjs/public_html/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php(2798): apply_filters('wpml_active_lan...', Array, Array) #3 /mnt/BLOCKSTORAGE/home/219772.cloudwaysapps.com/snkvzuwbjs/public_html/wp-content/plugins/sitepress-multilingual-cms/inc/template-functions.php(110): SitePress->get_ls_languages(Array) #4 /mnt/BLOCKSTORAGE/home/219772.cloudwaysapps.com/snkvzuwbjs/p in /mnt/BLOCKSTORAGE/home/219772.cloudwaysapps.com/snkvzuwbjs/public_html/wp-content/plugins/types-access/application/models/wpml_settings.php on line 400
There has been a critical error on your website. Please check your site admin email inbox for instructions.

Thanks and regards
Simon