[Resolved] Access not working correctly

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Luo Yang 2 years, 2 months ago.

Assigned support staff: Luo Yang.

Author
Posts
#604564

Access was working fine on this website for a long time. Recently it no longer allows the author to edit their own. Nothing has changed in the Access settings. I have disabled all plugins except Toolset and the problem continues (so not plugin conflict). I tried adding a new user and a new page - still did not work. Access is set up correctly (see attached)

#604628

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Dear Seb,

The problem you mentioned above is abnormal, in case it is a compatibility problem with your theme files, please try these:
1) deactivate other plugins and switch to wordpress default theme, and test again
2) If the problem still persists, please provide a database dump file (ZIP file) of your website in below private detail box, I need to test and debug it in my localhost, thanks

#604785

Hi Luo. I have the SQL database dump file .zip if you require it? Please open up a hidden file upload area if you wish me to send it to you?

#604926

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

The SQL database dump file .zip isn't required, I am checking it in your website, will feedback if there is anything found

#604927

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

I tried it in my localhost, there isn't same problem.
Then I checked it in your website:
it is a problem of Adminimize plugin, you can simply deactivate it and test again。
For debug this problem, I just enabled the User Switching" plugin in your website, and switch to editor user "A Test", edit the post "Atest", see screenshot: access2.JPG