Skip Navigation

[Resolved] Access not allowing access to user below Admin to Elementor to make changes

This thread is resolved. Here is a description of the problem and solution.

Problem:

If I am an Editor I get this message "You need a higher level of permission." when trying to navigate to Elementor template.

Solution:

You can use Access plugin to control the permission to Elementor template post type, for example:

https://toolset.com/forums/topic/access-not-allowing-access-to-user-below-admin-to-elementor-to-make-changes/#post-1628493

Relevant Documentation:

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will start replying to tickets in about 0.13 hours from now. Thank you for your understanding.

Author
Posts
#1613163

I've disabled all plugins but Toolset Access and Elementor (test site)

If I am an Editor I get this message "You need a higher level of permission." when trying to navigate to
/wp-admin/edit.php?post_type=elementor_library&tabs_group=library

This is the standard Elementor template area used by all my Editors to do their work on production with out me elevating them to ADMINs.... which I really don't feel good about.

not sure why this is suddenly happening, I've tested it on two separate installs.

It feels very much like this: https://toolset.com/errata/users-below-admin-role-cannot-access-custom-post-types-in-the-backend-if-the-post-types-plural-name-is-not-latin-or-has-spaces/

Please let me know if I can offer any more assistance, I would like to remove this level of access ASAP, and cant just disable Acesss, or Elementor.

Cheers
Stuart

#1613613

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

I would like to know the access details you shared with your initial post is for your test site? If no, Can you please send me access details to your test site with both admin and editor user access details.

*** Please make a FULL BACKUP of your database and website.***
I would also eventually need to request temporary access (WP-Admin and FTP) to your site. Preferably to a test site where the problem has been replicated if possible in order to be of better help and check if some configurations might need to be changed.

I have set the next reply to private which means only you and I have access to it.

#1614625

It is a test site - NOT production - you are fine to run some tests.

And I have a backup...

Create yourself an Editor user and test - you will notice there is not default /wp-admin login, I've customised this.

#1614981

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Hello,

Minesh is on vacation, will be back on Friday, you will get answer when he is back.

#1616449

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

I have tried the credentials you provided above:
https://toolset.com/forums/topic/access-not-allowing-access-to-user-below-admin-to-elementor-to-make-changes/#post-1613163

I can see only a password window, see screenshot pass-win.JPG, please check it.

Since it is a compatibility issue with elementor plugin, you can also provide a copy of your website in below private message box, so we can test and debug it in localhost, thanks
https://toolset.com/faq/provide-supporters-copy-site/

#1617541
#1619439

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Thanks for the details, I am downloading the files, will update here if there is anything found.

#1619459

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

I can install the duplicator package in my localhost, but I don't see the problem as you mentioned above:
If I am an Editor I get this message "You need a higher level of permission." when trying to navigate to
/wp-admin/edit.php?post_type=elementor_library&tabs_group=library

See my screenshot: Saved-Templates.JPG, is there any step missing?

I created a new administrator user to test above URLs, it works fine.

#1623551

It is fine for the admin users, but for Editors the issue exists... and only until recently.

#1623785

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Thanks for the details, I can see the problem with your duplicator package, please try these:
1) Add below PHP codes into your theme file "functions.php"

	add_filter('toolset_filter_exclude_own_post_types', function($initial_list){
		foreach($initial_list as $k => $v){
			if($v == 'elementor_library'){
				array_shift($initial_list);
			}
		}
		return $initial_list;
	});

2) Dashboard-> Toolset-> Access Control-> Custom Post types,
Find post type "My Templates", enable option "Same read permission as posts", save and test again.

#1626757

1) Add below PHP codes into your theme file "functions.php"

- I added to the Toolset Code area, I hope this is fine? Rather than functions.

2) Dashboard-> Toolset-> Access Control-> Custom Post types,
Find post type "My Templates", enable option "Same read permission as posts", save and test again.

There is no post type called 'My Templates'... see image (Id however try the 'Elements' CPT as I didn't know what that one was).

#1628493

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

I have done below modifications in your website:
1) Edit theme file functions.php, add below codes:

add_filter('toolset_filter_exclude_own_post_types', function($initial_list){
    foreach($initial_list as $k => $v){
        if($v == 'elementor_library'){
            unset($initial_list[$k]);
        }
    }
    return $initial_list;
});

2) Dashboard-> Toolset-> Access Control-> Custom Post types,
Find post type "My Templates", enable option "Managed by Access", save.

Please test again, check if it is fixed. thanks

#1628597

My issue is resolved now. Thank you!