Skip Navigation

[Resolved] Access Control Noting Working for BbPress

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Author
Posts
#1379075
User cannot post topics.PNG
How forum should look.PNG

I am trying to:

I updated Toolset plugins to the most reason versions. Upon doing so, users, even if allowed in permissions, are no longer able to post in Bbpress forums. Only the admin user type is able to post in Bbpress forums. When a user goes to a forum, they get the message "You cannot create new topics" or within a topic, the message "You cannot create new topics." This did not happen in the previous versions of Toolset I was using.

I have rolled back my live site to the earlier versions while this is fixed, but I am keeping it on my dev site so that you can inspect the issue.

The versions I had before and the versions that they are now:

Toolset Access Version 2.6.1-->2.8.1.3

Toolset Forms 2.2.1.2 -->2.5.2

Toolset Layouts Version 2.5.2-->2.6.2

Toolset Types Version 3.2.4-->3.3.6

Toolset Views 2.7.2-->2.9.3

Toolset WooCommerce Views 2.7.7-->2.7.11

Link to a page where the issue can be seen: hidden link

I expected to see:

The ability for a user authorized to post in the forum. If the user is the site role "Wayne State Student", they should be able to post on this page.

Instead, I got:

It says "You cannot create new topics" even for authorized users.

#1379395

Okay thank you for the report. After examining your site's setup I was able to replicate the problem on my own local environment. It seems that the Access update breaks how Access was previously overriding the bbPress forum permissions. I need to escalate this to my 2nd tier support team for additional investigation. Please stand by and I will let you know what I find out.

#1380945

I have an update. This issue has been escalated to our developers for resolution. In the meantime, my 2nd tier support team proposed a workaround:
- Go to Toolset > Access control > Custom role
- Click enable advanced mode
- Click change permissions for the Wayne State Student role
- In other capabilities, add keep_gate and click change permissions.

Let me know if this workaround does not completely resolve the issue for you. It seems to solve the problem on my local instance.

#1381081
Access deactivated.PNG

Thank you for your help. I tried to do use Access, but strangely, it seems I am unable to now. The plugin is deactivated and even when I try to activate it, it seems to stay deactivated. Can you log in and take a look?

Also, it seems as of yesterday there are updates for Toolset Forms, Types, and Views. Is it best to hold off on updating until we sort everything out?

#1381103

Hi, so I turned off all plugins and used the theme twenty fourteen and it seems I am able to turn it on again. I am going to test and see if I can find which plugin might be conflicting with it.

#1381179
WooCommerce conflict fatal error.PNG

Ok, so after testing I think I am able to identify the conflicting plugin: WooCommerce version 3.2.5

Trying to activate Toolset Access while it is on causes the error "Plugin could not be activated because it triggered a fatal error". However, activating Toolset Access first and then WooCommerce for some reason seems to get around this issue. Now that I have Access working I will try the fix you mentioned and then will try to update WooCommerce to see if that fixes this issue.

#1381429

Hi, I just tried your fix and it seems to work. I will let you know if anything chages. Thank you for the help and I look forward to the update from the developers.

#1471279

Hi, just wanted to check the status of any upcoming updates. I have noticed that while a user has the keep_gate permission, they can see other users' IP addresses, so ideally I would like to remove this permission. Thanks!

#1471473

Hello, I can see there has been development activity on this issue as recently as last week. The proposed solution appears to be under testing, and a release schedule has not yet been confirmed. I expect some action on this relatively soon, though I can't be very specific on the timeline. As soon as I have more concrete details, I will let you know.

#1486823

Hi, I have received information today that indicates the permanent fix for this issue will be included in the next release, Access 2.8.4. I don't have a delivery date yet, but wanted to let you know the next version of Access will include the fix so you can be prepared. I will update the ticket here to let you know when the new version is available for distribution.

#1487003

Great, thank you!

#1514921

Please find Access 2.8.4 available for automatic update or download at https://toolset.com/account/downloads and update all Toolset plugins to the latest versions. Let me know if the problem is not completely resolved. Thanks for your patience while we worked to resolve this issue.

#1518845
Cannot reply to topics.PNG

Hi, Christian,

Thank you for your help. Unfortunately, I am still having issues.

After the update, it seems like users can now post in forums if they are authorized to, but still cannot post not topics or replies. Would it be possible for you to take a look? Maybe things are not configured correctly on my end?

New threads created by Christian Cox and linked to this one are listed below:

https://toolset.com/forums/topic/unable-to-post-replies-in-bbpress-despite-access-control-settings/

#1518869
Cannot reply to topics error.PNG

I also wanted to mention that it seems like the keep_gate permission doesn't seem to bypass this issue. It will allow users to see the text field to reply to a topic or reply, but when they try to post they get an error "ERROR: You do not have permission to reply."

So I am not sure if there is a workaround.

#1518891
Some replies will not post.PNG
Access Permission Settings.PNG
Other permissions checked.PNG

Sorry, I have one more update.

So it seems like I might have gotten it to work to an extent using "other permissions". I checked off "publish_replies", and "publish_topics" and it seems like I can post topics now.

However, this shouldn't be necessary if I have the correct permissions checked for Access Post Type permissions right? Attached is a picture of the permissions I have checked off.

The problem is with these settings is that it seems like some replies do not post. In the screenshot below, you can see the reply after #33121 is #33124 because the #33122 and #33123 did not seem to post.