Skip Navigation

[Resolved] 1 User role not redirected to "My Account" – 2 others are

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by MargeP6083 11 months ago.

Assigned support staff: Nigel.

Author
Posts
#1749085

I have multiple user roles who use the /my-account/ to login and should redirect to the same page.

hidden link

Users who have Pending Industry and Industry roles are re-directed to the Woocommerce account page: hidden link. I can't override or remove this behavior.

Other 2 roles, talent and casting roles, are able to login and redirect correctly to /my-account/.

Is there another setting I am missing?
Thank you!

#1753295

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

Hi Marge

I visited your site, and see the key part of the my-account page is this log-in link for guests:

[wpv-login-form redirect_url="<em><u>hidden link</u></em>"]

Looking at the roles (at Toolset > Access > Custom Roles) I can't see anything that would account for the difference.

Do you have a staging site for testing?

Can you confirm if the same happens in a minimal environment? That is, with all non-Toolset plugins except WooCommerce disabled, running a standard theme such as twentytwenty, and with any custom code disabled.

That would help eliminate the possibility of some conflict with other code causing the problem, and if that's the case you can use a process of elimination to identify the source of any such conflict.

#1754151

I opened a ticket with woocommerce. Thank you!