Skip Navigation

[Resuelto] When I create a new post type, button says "submit for review"

This support ticket is created hace 3 años, 8 meses. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 - -
13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 - -

Supporter timezone: America/New_York (GMT-04:00)

This topic contains 3 respuestas, has 2 mensajes.

Last updated by Christian Cox hace 3 años, 8 meses.

Assisted by: Christian Cox.


Hi there,

I am trying to create a new post type, and when I try to save it, the button says "Submit for review".

How do I review? And why would this start happening all of a sudden?

Kind regards,


Normally this happens when you are logged in as a User with a User role that does not have permission to publish posts in this post type. The User is able to submit the post for review, and another User in a higher level role would have to publish it. What User role is your current User? Are you using Access to manage permissions?


Hi Christian,

Thanks for getting back to me.

I found the issue, it was a custom function to move the Featured Image meta box to the top. When I removed the function, it worked as expected again.

On another note though, I am trying to display a view based on date. I have my CPT (Online Events) with entries which have dates set before and after today. These all display fine when "The field Online Event Date is a DATE that is greater than or equal the following: TODAY" is removed. But as soon as I add it in, I get the message that no online events can be found.

Any ideas as to why the view won’t work when this filter is enabled?

Kind regards,

New threads created by Christian Cox and linked to this one are listed below:


Okay great, I'm splitting your custom field date range filter question into a separate ticket so we can keep things organized here. I'll follow up in the new ticket shortly.

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.