Skip Navigation

[Resuelto] Using Category Links as Table Headers — I Cannot Get Them To Sort Properly

This support ticket is created hace 4 años, 7 meses. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Hong_Kong (GMT+08:00)

Etiquetado: ,

This topic contains 1 respuesta, has 2 mensajes.

Last updated by Luo Yang hace 4 años, 7 meses.

Assigned support staff: Luo Yang.

Autor
Mensajes
#916392

I’ve created a table here: hidden link

You can sort most of the table columns by clicking on the headers, but the category column (called Industry) does not allow sorting. Can you advise how I should alter my code?

Here is the code from the view. It was built using the Loop Wizard:

[wpv-layout-start]
[wpv-items-found]
<!-- wpv-loop-start -->
<table width="100%">
<thead>
<tr>
<th>[wpv-heading name="post-link"]Listing Name[/wpv-heading]</th>
<th>[wpv-heading name="types-field-location"]Location[/wpv-heading]</th>
<th>[wpv-heading name="taxonomy-link"]Industry[/wpv-heading]</th>
<th>[wpv-heading name="types-field-asking"]Asking Price[/wpv-heading]</th>
<th>[wpv-heading name="types-field-gross"]Gross Revenue[/wpv-heading]</th>
<th>[wpv-heading name="types-field-cash"]Cash Flow[/wpv-heading]</th>
<th>[wpv-heading name="types-field-date-added"]Date Added[/wpv-heading]</th>
</tr>
</thead>
<tbody class="wpv-loop js-wpv-loop">
<wpv-loop>
<tr>
[wpv-post-body view_template="Loop item in Listings Table"]
</tr>
</wpv-loop>
</tbody>
</table>
<!-- wpv-loop-end -->
[/wpv-items-found]
[wpv-no-items-found]
[wpml-string context="wpv-views"]No items found[/wpml-string]
[/wpv-no-items-found]
[wpv-layout-end]

#916469

Luo Yang
Supporter

Languages: Inglés (English ) Chino simplificado (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Hello,

I just tried it in my localhost with same codes as you mentioned above, but there isn't similar problem, please check these in your website:

1) Make sure you are using the latest version of Toolset plugins, you can download them here:
https://toolset.com/account/downloads/

2) Deactivate other plugins and switch to wordpress default theme 2017, and test again

3) If the problem still persists, please provide provide a database dump file (ZIP file) of your website in below "private detail box", I need to duplicate same problem and debug it in my localhost, thanks.