Skip Navigation

Updating Custom Post never completes

This support ticket is created hace 9 años, 9 meses. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 11 respuestas, has 3 mensajes.

Last updated by Craig hace 9 años, 9 meses.

Assigned support staff: Luo Yang.

Autor
Mensajes
#31929
Therapy Custom Post Type.png

Hi there,

I received some help from Luo a while back to set up a telephone like directory listing (https://toolset.com/forums/topic/create-an-alphabetical-listing-like-a-telephone-directory/)

I am now trying to update some of the entries, but after I make a change and clicking the Update button, it never stops trying to update (see attached screen grab). This happens both on a localhost development server and on live site at hidden link.

I have another Custom Post type which I can update normally, so it’s not an issue with connecting to the database, it just appears to be this particular Custom Post type.

WordPress 3.5
Types Version 1.1.3.3
Views Version 1.1.3.2

I can create a temporary login if required. Just let me know.

Hope someone can shed some light on this as it is causing me no end of grief.

#31990

Luo Yang
Supporter

Languages: Inglés (English ) Chino simplificado (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Hi Craig,

Could you enable WP debug mode, repeat actions you mentioned above, and post the debug log here.
Also check if there is any JS error.

https://toolset.com/documentation/user-guides/debugging-types-and-views/

PHP Debugging
In case you think that Types or Views are doing something wrong (what we call a bug), you should enable PHP error logging. Again, edit your wp-config.php file and add the following:

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . '/error_log.txt');
This will produce a file called ‘error_log.txt’ in your WordPress root directory. Make sure that the web server can create and write this file.

If it cannot, use an FTP program to create the file and make it writable to Apache (normally, user www-data).

Regards
Luo

#32024

Hi Luo,

I just enabled "define('WPV_LOGGING_STATUS', 'info');" and tried the page again – nothing showed up in the console.

No sign of JavaScript errors either (nothing showing in the console anyway, is that where they would be displayed?)

I also enabled PHP Debugging and the only error it threw up was:
[19-Dec-2012 08:03:26] PHP Notice: Undefined index: every12hours in /home/cbddev/public_html/borders-therapies/wp-includes/cron.php on line 103

Don't know if that helps any?

EDIT: just as an update, I tried in Firefox and Safari and the same thing is happening in those browsers too.

Craig

#32197

Luo Yang
Supporter

Languages: Inglés (English ) Chino simplificado (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

There isn't any error in your debug log.

And I can not duplicate same problem in my localhost, could you try this:
Deactivate other plugins and switch your theme to twentyeleven, and test again

You are welcome to set a test site using our http://discover-wp.com system. You can set a test site there in few minutes, reproduce the problems and share with us the access details so we will be able to review it.

#32220

I have changed theme to TwentyTwelve and disabled all plugins apart from Types & Views.

Unfortunately the problem still exists.

I will try recreating on discover-wp.com and let you know when done.

Is there any way I can make some changes to the individual post types directly in the database? I need to attach a Content Template to each of the posts urgently.

Kind regards,

Craig

#32271

Hi Luo,

I have tried importing the Types and Views info into a new site on discover-wp.com, but I cannot import existing posts and pages etc, so very time consuming to recreate.

Could I send you a BackupBuddy archive to see if you can install on a local environment to see if you can see what is going wrong?

Let me know if this would be OK. Otherwise, I can give you access to the development site online.

Kind regards,

Craig

#32276

Out of curiosity, are you using Chrome as your browser?

I've noticed a very similar issue on my sites, as well, and figured out that it was actually due to the use of the HTML5 "required" and/or the more specific HTML5 input types. When you try to submit a form with a "required" element, or something like an "email" or "number" field, and the browser doesn't find a valid value in the that field, the browser stops the form from actually being submitted. Instead, in WordPress, the little spinner keeps spinning and nothing ever happens.

When this happens, you might want to expand all of the metaboxes (make sure none of them are collapsed), then look for any validation messages. Most recently, in my case, I had a required field in the third metabox down, and I had that metabox collapsed at the time. When I submitted the form, the spinner started spinning and nothing ever happened. However, once I expanded that third metabox, I saw Chrome's error message about the field being required.

#32290

Awesome catch Cathy, thank you. Although, it did the same in Firefox and Safari.

I looked in the Screen Options section, and there were two metaboxes hidden, one of which had 2 required fields, so what you mentioned was 100% correct, the form would never be submitted due to the required fields not being filled in.

Now to try and find out why that particular metabox is being displayed on that custom post type, as it should only be attached to another custom post type.

Now I'm heading in the right direction. I'll report back once I've found the culprit, but thank you Cathy for pointing out what should really have been something I should have checked out myself hangs head in shame

Best,

Craig

#32295

Cathy, just to let you know, I found the culprit after your advice to check for required fields.

I was displaying custom fields which were not necessary on that screen and have now removed them (oh how one blummin' checkbox can cause so much hassle!!).

It would have taken me a lot of time to narrow that down without your guidance, so I send you a hearty amount of thanks and Christmas cheer.

Thank you also to Luo for being so patient with me whilst I get my head around this fantastic suite of plugins.

Craig

#32300

Fantastic. I'm glad you were able to get it worked out. I probably wouldn't have spotted it, either, except that I spent about 45 minutes last night wrestling with a very similar issue.

I hope you have an awesome Christmas, too.

#33016

Luo Yang
Supporter

Languages: Inglés (English ) Chino simplificado (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Craig, Is this problem resolved? Please let me know if you need more assistance.

#33031

Hi Luo,

Sorry, with the lead up to Christmas, I forgot to close the topic. It all resolved, thank you.

Kind regards,

Craig