Skip Navigation

[Resuelto] Under a multisite setup I can’t see custom fields on my custom post types

Este hilo está resuelto. Aquí tiene una descripción del problema y la solución.

Problem: Custom field groups assigned to a post type are missing on the post edit screens for that type.

Solution: A caching issue was preventing the custom field metaboxes being shown. Flushing the cache resolved the problem.

Este es el foro de soporte técnico para Toolset: un paquete de plugines para el desarrollo de sitios WordPress sin escribir PHP.

Cualquier persona puede leerlo, pero solo los clientes de Toolset pueden publicar en este foro. El soporte de Toolset atiende 6 días a la semana, 19 horas por día.

This topic contains 4 respuestas, has 2 mensajes.

Last updated by Cesar hace 2 años, 4 meses.

Assigned support staff: Nigel.

Autor
Mensajes
#1247921

The most basic operation, adding a custom field on a custom post type with not a single plugin and the default WP theme fail to show the custom field of my cpt

I've try to enable the plugin per site and also per network with same result

**EDIT
It seems to be a server issue, could you please confirm that there is nothing wrong with the log I share?

Thanks

#1248081

Nigel
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/London (GMT+01:00)

Hi there

You say "not a single plugin" but you presumably mean you have at least Types active?

When you say "fail to show the custom field of my cpt" are you talking about on the front end or on the back end edit screens?

If you have messages in your debug log related to this then please share that here for me to see.

#1248291
Captura de pantalla 2019-05-23 a las 12.26.10.png

That's right, only Toolset was installed.

And the issue is related with the backend.

I try to do the basic, create a CPT assign some Fields and when I check on the backend of my new post from CPT Fields doesnt appear.

I really need some help debugging the issue so that I can give some info to the hoster. I tried just the same with a regular installation. No multisite and got same result

Thanks

#1249159

Nigel
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/London (GMT+01:00)

I notice from your debug info that you are using an old version of Types. Could you please replace that with the current version (3.3). I also note from your screenshot that WPML is active. For the purposes of testing, can you please try with Types and nothing else active and see if you see the same problem.

It looks like a server issue (a 400 error is a bad request, not a PHP error), but let's test with the current version of Types first.

To save time let me also get your site credentials (preferably the single site install if you still have it available) so that I can take a look myself. I'll set up a private reply for that.

Also, can you check your logs for warnings or errors?

If you haven't already, turn on the debug log by editing your wp-config.php file and change the line with WP_DEBUG like so:

define('WP_DEBUG', true);
define('WP_DEBUG_LOG', true);
define('WP_DEBUG_DISPLAY', false);

That will create a debug.log file in your /wp-content/ directory which you can examine in any text editor. Try visiting the same page and then inspect the log. If you don't find the debug.log file it means it didn't generate any warnings or errors.

#1250709

My issue is resolved now.

It was related with the server caching the database, I had to flush the cache in order to see the changes.

Hope this server won't cause me any more problems

Thank you!