Skip Navigation

[Resuelto] Sidebar appearing at the bottom of the page

This support ticket is created hace 4 años, 5 meses. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 6 respuestas, has 2 mensajes.

Last updated by ericL-12 hace 4 años, 4 meses.

Assigned support staff: Nigel.

Autor
Mensajes
#716857
Screenshot (54).png

I am trying to: Setup my layouts

Link to a page where the issue can be seen: hidden link

I expected to see: No sidebar.

Instead, I got: Sidebar at the bottom.

#717399

Nigel
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/London (GMT+01:00)

Hi Eric

The sidebar is getting added by WooCommerce in conjunction with your theme, even though you are using the WooCommerce Views template for single product posts.

You'll need to do the following:

- make a folder 'woocommerce' in your theme directory, and copy the single-product.php template from plugins/woocommerce-views/templates/single-product.php

- edit the file you just copied and comment out lines 74 and 83, i.e.

// do_action('woocommerce_after_main_content');

// do_action('woocommerce_sidebar');

Go to Toolset > WooCommerce Views and for the product template file choose the custom product template from your theme (the file you just edited).

That should prevent WooCommerce adding the sidebar to the page.

#727575

Hello Nigel,

I did what you said and it's still showing the sidebar.

#731762

Nigel
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/London (GMT+01:00)

Hi Eric

I looked at your settings in Toolset > WooCommerce Views and the copied version of the template is not showing up as a custom theme template you can use for single posts.

It looks like you copied the template into your parent theme but I think it needs to be in the active (child) theme to be recognised. Could you make the /woocommerce/ folder in your child theme and copy the template to there and see if it then appears as an option in Toolset > WooCommerce Views for the single product template?

#741537

Nigel
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/London (GMT+01:00)

Hi Eric

I have another client reporting the same thing with the flatsome theme and I'm going to escalate this to see if my colleagues can identify a possible fix other than the edits I suggested.

I'll let you know when there is something to report.

#787998

Hello Nigel,

Do you have an approximate date for this to be solved? We are launching the site in about 4 days. Maybe a css trick to hide sidebar in some custom posts but not in other ones?

Thank you,

Eric

#862598

Thank you