Skip Navigation

[Resuelto] Results are not showing what they should

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Etiquetado: 

This topic contains 9 respuestas, has 2 mensajes.

Last updated by Christian Cox hace 1 año, 7 meses.

Assigned support staff: Christian Cox.

Autor
Mensajes
#1505235

I am trying to:
Create a taxonomy filtered results view for a links similar to this one hidden link. But results are only showing the first one, and repeated 4 times (there are 3 recipes under this taxonomy).

Link to a page where the issue can be seen:
hidden link

I expected to see:
When you click on a Taxonomy term like "Main Course", that you can find here hidden link, I would like to have all the recipes related to this term listed on a page like results of a search similar to this one hidden link

Instead, I got:
hidden link

#1505663

Hello, can you take screenshots showing the View configurations in wp-admin and include those in your next reply?

#1505687
view screenshot.jpg

Is this ok?

#1505697
Screen Shot 2020-02-12 at 1.39.19 PM.png

This is a View of taxonomy terms, not a View of posts. I think the Content Selection is incorrect. You should select the recipes post type not the Moments of the Day taxonomy. Then you can filter by taxonomy term slug set by a shortcode attribute moment-of-the-day. Here is an example showing this type of Query Filter. If you cannot see the Query Filter panel in the View editor screen, scroll to the top right corner and click "Screen Options" to enable the Query Filter.

#1505731
Main Course filter TAJIN.jpg
Edit View ‹ TAJIN — WordPress.png

I did what you told me and modified the view. (screenshot)

But now is not filtering nothing, when is supposed to show only recipes for "Moments of the day >> Main Course".

I'm doing something wrong and don't know exactly what.

#1505753

Your query filter is set to respond to a URL parameter wpvmomentoftheday, so the URL should look like this:

hidden link

Is this showing the correct results?

#1505761
Edit View ‹ TAJIN — WordPress (1).png

I've modified the filter setting (screenshot) and now it seems to be working.

hidden link

I don't know if there's a better way to do it.

#1505771

Is this a WordPress Archive, or a View? If it's a WordPress Archive, this should be fine.

#1505773

It's an archive, now I understand how this works.
Thanks a lot for your help!

#1505783

You're welcome. Closing per user comments.