Skip Navigation

[Resuelto] Profile link not showing, not found theme profile page.

Este es el foro de soporte técnico para Toolset: un paquete de plugines para el desarrollo de sitios WordPress sin escribir PHP.

Cualquier persona puede leerlo, pero solo los clientes de Toolset pueden publicar en este foro. El soporte de Toolset atiende 6 días a la semana, 19 horas por día.

This topic contains 6 respuestas, has 3 mensajes.

Last updated by andresG-3 hace 1 año, 6 meses.

Assigned support staff: Jamal.

Autor
Mensajes
#1657131

Tell us what you are trying to do?

I found that that profile in english version is not working
hidden link

this is working ok
hidden link

I have installed WPML, my guess that I had a problem with the wp theme generated for english version.

#1657171

Jamal
Supporter

Languages: Inglés (English ) Francés (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello and thank you for contacting the Toolset support.

Let me try to help you in English on the Spanish support, as you have created the ticket in English. Please let me know if you would prefer a Spanish talking supporter.

Please make sure that the profile post is translated into English and that the translation is complete.
If you are using a content template, make sure it is also translated following our article https://toolset.com/documentation/translating-sites-built-with-toolset/translating-content-templates-wordpress-archives-and-views/

Make sure, that the custom post type slug "perfil" is translated correctly to English in String Translation or in WPML->Settings->Post Types Translation.

Then, save the permalinks again in Settings->Permalinks.

If all this does not help, please check if this issue appears when:
- Only Toolset and WPML plugins are activated. It will tell us if there is an interaction issue with another plugin.
- The theme is set to a WordPress default like Twenty Fourteen. It will tell us if there is an interaction issue with your theme.
If the problem disappears, start activating one at the time to track where the incompatibility is produced.

If this does not help, I'll need to take a closer look at your website for further analysis. Your next reply will be private to let you share credentials safely. ** Make a database backup before sharing credentials. **

#1657243

The profile post are all translated from a long time ago. But at certain point start to fail. I will try this firsts steps to see if it helps. Thanks for your help I will get back to you soon.

#1658237

Minesh
Supporter

Languages: Inglés (English )

Timezone: Asia/Kolkata (GMT+05:30)

Jamal is on holiday today. He will get in touch with you as soon as you reply here.

#1660047

Jamal
Supporter

Languages: Inglés (English ) Francés (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello. I am back again, let me know what you will get.

If the issue persists, I'll need to take a closer look at your website for further analysis. Your next reply will be private to let you share credentials safely. ** Make a database backup before sharing credentials. **

#1670817
after-update-still-persist-page-not-found.jpg
fatal-error-wpml.jpg

Please make sure that the profile post is translated into English and that the translation is complete.
If you are using a content template, make sure it is also translated following our article

Hi Jamal! thanks for your help!! the default language for this website is english so spanish is the translation. It seems there is a problem with the profile content template for english version, its weird because spanish version shows the profile correctly.

This site was working ok since 2018 and do not change at all for a while, but perhaps some automatic wordpress update performed by siteground start to cause this error. Content template was working ok originally, I prefer that you check this from your end. I will provide temporary access to wp backend.

I search for the error message in google, i dont know if this is something related to my case
https://wpml.org/es/forums/topic/error-fatal-de-php-no-permite-enviar-trabajos-de-traduccion-a-traductores/

First I update Toolset to the latest version but the error persists.

Then I update all the wpml plugins to the latest version to check if it is an error related to that. Error persist

Also try to update Beaver builder, when I did this the problem was solved right away!

Didnt find where to update permalink settings

#1672045

Jamal
Supporter

Languages: Inglés (English ) Francés (Français )

Timezone: Africa/Casablanca (GMT+01:00)

You can update permalinks in Settings->Permalinks, check this screenshot hidden link

The WPML error is outdated, I am pretty sure it was fixed by latest WPML versions. I understood, that the issue was resolved after updating Beaver builder, right?
If it is not the case, please take a full backup and allow me temporary access to check your website closely. Your next reply will be private to let you share credentials safely.