Skip Navigation

Problema al configurar notificaciones desde formulario

This support ticket is created hace 4 años, 10 meses. There's a good chance that you are reading advice that it now obsolete.

Este es el foro de soporte técnico para Toolset: un paquete de plugines para el desarrollo de sitios WordPress sin escribir PHP.

Cualquier persona puede leerlo, pero solo los clientes de Toolset pueden publicar en este foro. El soporte de Toolset atiende 6 días a la semana, 19 horas por día.

This topic contains 13 respuestas, has 2 mensajes.

Last updated by Beda hace 4 años, 10 meses.

Assigned support staff: Beda.

Autor
Mensajes
#585624
Sin título.jpg

Hola,

estoy generando un formulario, todo funciona corréctamente, pero cuando voy a generar notificaciones me sale el siguiente error: "Esta notificación no está configurada adecuadamente porque algunos ajustes no están completos. Controle y seleccione los valores. "

Ahora mismo, el formulario se muestra corréctamente en la web pero no envía nada. El correo está configurado correctamente en wordpress, pero no hay forma de que se guarde la configuración para enviar dicho formulario, lo configuro, le doy a guardar, y cuando reviso, no está.

Otra cosa tambien es que cuando le digo: "Enviar notificación a un correo especificado en un campo de formulario:", no aparece ningún campo email ni nombre ni apellidos.

Muchas gracias.

Un saludo.

#585725

Esto es resuelto en la ultima version de CRED y Types que fueron publicados ahier.

Puedes actualizar y re-intentar?

#586158

Hola, gracias por la respuesta, he conseguido configurarlo pero no sé por qué no envía los formularios, veré si es por la configuración del wordpress , hay alguna recomendación para configurar correo que funcione bien con toolset?

Gracias de nuevo.

Saludos.

#586165

Buenas de nuevo,

he conseguido que me envie el correo a una dirección específica, lo que no consigo es que lo haga a un campo de email (porque no me aparece ninguno en las opciones) y cuando envío a la dirección específica, lo hace pero sale en blanco, no me llega nada en el email nada más que el asunto y en el mensaje está puesto el %%FORM DATA%%

Gracias.

Saludos.

#586218

La %%FORM_DATA%% en el momento no funciona bien y los desarolladores ya están informados de esto.

lo que no consigo es que lo haga a un campo de email (porque no me aparece ninguno en las opciones)

El campo de email esta en el formulario?
En este caso, ya intentaste a hacer click en el reload de el setting en la notificación misma donde controlas el campo por el email?

En caso que esto no ayuda por favor también controla la pagina de errores conocidos aqui:
https://toolset.com/known-issues/

Por CRED hay varios problemas de notificaciones con soluciones.

En caso todo esto no funciona, me puedes mandar una copia de este sitio con una descripción de donde quieres añadir qual notificación?
https://toolset.com/faq/provide-supporters-copy-site/

Gracias!

#587028

He activado una forma privada.

Puedes me indicar el log in y también todos los links a donde veo los problemas?

#587095

Creo que puedo replicar esto problema localmente.

He escalado este Thread a lost desarolladores.

#587115

Por favor añada esto en el campo de CRED genérico:

"persist":1,

Por favor añada esto en modo de obtener un campo codificado así:

[cred_generic_field field='toolset_email_generic' type='email' class='' urlparam='']
{
"required":1,
"persist":1,
"validate_format":0,
"default":""
}
[/cred_generic_field]

Después guarda la forma y re-edita la notificación.
El campo ahora debería estar allí, en caso que no por favor utiliza la flecha azul para recargar los campos, justo a la mano derecha de el setting en las notificaciones.

#587328

Muchas gracias,

En cuanto al otro problema, cuando estará solucionado?

Gracias de nuevo.

Saludos.

#587482

Te refieres a el %%FORM_DATA%% que no aparece en el email?

En esto todavia estamos trabajando y te puedo informar aquí cuando es resuelto.

Vale?

#590347

Hola de nuevo,

acabo de actualizar a la última versión y sigue fallando, ahora si que envía el email, lo recibo, pero solo me muestra los campos Nombre y e-mail. No muestra nada más.

Gracias.

#590520

Sugiero de abrir un ticket nuevo por el problema.

Puedo explicar porque:
- este ticket ess relacionado a el especifico problema (ya resuelto) donde no se podia añadir certos valores a el email.
- yo no sera aqui la semana siguiente.

Por favor, si posible, puedes abrir un ticket nuevo describiendo exactamente el contenido de la CRED y su notificación.
Sera favrobale por el supporter tener un export de estas formas, talves, para replicar el problema.

No he encontrado problemas en los testes de acuerdo a las descripciones, pero puede ser que un setting especifico cause el problema.

Muchas gracias pro entender!

#591722

Hola,

sigo teniendo el fallo, no sé por qué, no llega correctamente los campos de data form, solo llegan el nombre y correo electrónico.

Gracias!

#593953

Por favor puedes abrir un ticket nuevo, describiendo el problema en detalle?
Esto thread aqui es resuelto:

estoy generando un formulario, todo funciona corréctamente, pero cuando voy a generar notificaciones me sale el siguiente error: "Esta notificación no está configurada adecuadamente porque algunos ajustes no están completos. Controle y seleccione los valores. "

Esto es resuelto. Debemos trabajar en los otros problemas en nuevos tickets.

Muchas gracias.