Skip Navigation

[Resuelto] No se actualizan los plugins a las últimas versiones

Este es el foro de soporte técnico para Toolset: un paquete de plugines para el desarrollo de sitios WordPress sin escribir PHP.

Cualquier persona puede leerlo, pero solo los clientes de Toolset pueden publicar en este foro. El soporte de Toolset atiende 6 días a la semana, 19 horas por día.

This topic contains 3 respuestas, has 2 mensajes.

Last updated by Nigel hace 1 año, 11 meses.

Assigned support staff: Nigel.

Autor
Mensajes
#1504805
2020-02-12_09h53_26_toolset_registered.png
2020-02-12_09h53_26_toolset_registered_2.png
2020-02-12_09h53_26_toolset_registered_3.png
2020-02-12_09h53_26_toolset.png

Estoy tratando de actualizar mis plugins Toolset a las últimas versiones disponibles pero al acceder a la página de Plugins de mi sitio web lo primero que veo es que aparece el warning Warning: Declaration of Installer_Upgrader_Skins::feedback($string) should be compatible with WP_Upgrader_Skin::feedback($string, ...$args) in /home/httpd/html/servicios/radio/wp-content/plugins/types/vendor/otgs/installer/includes/class-installer-upgrader-skins.php on line 26
/> en Toolset Types.

Aún así procedo a marcar solo el plugin Toolset Views para que actualice ya que ese no muestra ningún warning. Comienza el spinner para indicar que ha comenzado la actualización pero transcurrido más de una hora continua y no termina nunca la actualización.

Creo haber registrado correctamente he indicado la key perfectamente en el plugin en mi WordPress pero algunos módulos me dice que está pendiente de registrar pero luego al acceder para registrarlo , se ve claramente que sí está actualziada la key porque la fecha de expiración es enero de 2021.

URL de (mi) sitio web donde aparece el problema: hidden link

Yo esperaba ver: Tener instaladas las últimas versiones de Toolset pero sigo con versiones anteriores.

En vez de eso, obtuve: Siguen las mismas versiones que tenia instaladas antes de la actualización. Además aparece un warning.

#1504927

Nigel
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/London (GMT+00:00)

Veo que tienes versiones bastante antiguos.

Es el plugin Types que lleve el código del instalador.

Te recomiendo desactivar y borrar el plugin de Types actual, baja el archivo zip del versión corriente (desde toolset.com/account/downloads), y subir este archivo (en la página de agregar plugins).

Intenta de nuevo registrar el Types, y entonces creo que no tendrás tales problemas actualizar lo demás.

#1506797

Buenos días, Nigel.

Tengo un problema para hacer lo que me dices. Trabajo directamente en entorno de producción ya que la KEY y mi registro en Toolset solo me permite el uso de licencia en un único sitio web y no puedo hacer pruebas en mi entorno de preproducción. A no ser que me digas que es posible y me expliques como puedo probarlo antes en un entorno sin riesgo a interrumpir el servicio en producción.

Gracias.

#1506889

Nigel
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/London (GMT+00:00)

Solo puedes registrar un URL a la vez, pero puedes anular el registro del sitio de produción temporalmente para registrar lo de pre-producción para confirmar que funciona, y luego registrar de nuevo el sitio de producción...