Skip Navigation

[Resuelto] No envía el contenido del formulario al email

Este hilo está resuelto. Aquí tiene una descripción del problema y la solución.

Problem:
El cliente quiere usar unos campos genéricos en notificaciones de CRED pero no aparecen en los emails.

Solution:
Campos genéricos no se guardan en el base de datos por defecto, es necesario añadir el opción "persist":1.

This support ticket is created hace 4 años, 7 meses. There's a good chance that you are reading advice that it now obsolete.

Este es el foro de soporte técnico para Toolset: un paquete de plugines para el desarrollo de sitios WordPress sin escribir PHP.

Cualquier persona puede leerlo, pero solo los clientes de Toolset pueden publicar en este foro. El soporte de Toolset atiende 6 días a la semana, 19 horas por día.

Etiquetado: 

This topic contains 5 respuestas, has 2 mensajes.

Last updated by rafaelT-2 hace 4 años, 7 meses.

Assigned support staff: Nigel.

Autor
Mensajes
#611401

Estoy tratando de configurar dos formularios para mi web, uno que es contacto y otro presupuesto, en ambos no bien el envío, se recibe un email pero falta información, en el caso de presupuesto solo se reciben dos campos (nombre e e-mail) y en el caso de contacto se recibe en blanco.
Gracias.

Saludos.

#611656

Nigel
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/London (GMT+01:00)

Hola Rafa

Ambos formularios crean entradas, ¿verdad?

¿Qué contenido tienen las notificaciones en el cuerpo del mensaje?

¿Usan campos de Types incluidos en el mismo formulario?

#611968

Hola,

si, generan entradas, y aparecen en blanco, y si, hay campos incluidos de types en el formulario presupuesto.

Nunca ha funcionado desde que los he creado y tengo otras páginas que funcionan perfectamente formularios semejantes.

Gracias.

Saludos.

#612181

Nigel
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/London (GMT+01:00)

Me hace falta más.

Voy a marcar tu respuesta siguiente como privada para que me facilita acceso a tu sitio para ver el problema yo mismo. Si no es claro por que sale así, puedo sacar una copia para hacer pruebas utilizando el plugin Duplicator, si estás de acuerdo. Es una buena idea crear un nuevo usuario administrador para mi que lo quitas después, y asegúrate que tienes una copia de seguridad corriente.

¿De qué formularios hablamos?

#612921

Nigel
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/London (GMT+01:00)

Screen Shot 2018-02-05 at 15.45.24.png

Hola Rafa

Veo que en lugar de usar campos de entradas de Types utilices campos genéricos en los formularios.

No se guarda los valores de campos genéricos, a menos que pones el opción "persist": 1.

Veo que solo tienes este opción en el formulario de prestaciones para dos campos, nombre y email.

Ve en el pantallazo que estos dos campos se guardan, lo demás no, entonces los resultados no son inesperados.

#613025

Ok,

muchas gracias, ya he podido solucionarlo.

Un saludo.