Skip Navigation

[Resuelto] Nav Menu Roles not working with Layouts when logged in

This support ticket is created hace 5 años, 11 meses. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Hong_Kong (GMT+08:00)

This topic contains 7 respuestas, has 2 mensajes.

Last updated by triggeru571 hace 5 años, 11 meses.

Assigned support staff: Luo Yang.

Autor
Mensajes
#470977

I am trying to: Display certain menu items when logged in

I visited this URL:

I expected to see: A menu which should display only for logged in users

Instead, I got: An error saying the menu is not assigned (it is). Error occurs only when logged in. It is OK if set to everyone to see the menu

#470978

BTW - I am using the latest BETA for Layouts.

#471181

Luo Yang
Supporter

Languages: Inglés (English ) Chino simplificado (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Dear triggeru571,

How do you setup the nav menu?
Are you using other plugin/theme to setup the nav menu?
Could you provide a downloadable URL for it?
I need detail steps to duplicate same problem, thanks

#471249

Hi Luo, I actually removed Layouts completely now and all if fine. I was using the BETA layouts and the toolset theme when the problem occurred. If you wish to debug, simply download from here:

https://wordpress.org/plugins/nav-menu-roles/

Add Layouts BETA and your theme and child theme, then set some menu to display public and others for logged in users. You will see the logged in users does not work.

#471256

Luo Yang
Supporter

Languages: Inglés (English ) Chino simplificado (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Can you the same problem occur in the latest stable version of Layouts plugin 1.8.10?
Thanks

#471302

no it was working in 1.8. However, when I then upgraded to the Beta version and went back to 1.8 the stable version refused to load so I removed it. I don't need it anyway as I was just experimenting, but wanted to let you know.

#471403

Luo Yang
Supporter

Languages: Inglés (English ) Chino simplificado (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

I am not familiar with the plugin "nav-menu-roles", Can you take some screenshots for how do you setup the "some menu to display public and others for logged in users", what PHP errors did you get when logged in? could you post the PHP debug logs? thanks

#471817

Closed as I stopped testing layouts beta where this problem occured