Skip Navigation

[Resuelto] Map Not Rendering Unless Logged In

This support ticket is created hace 2 años, 8 meses. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Hong_Kong (GMT+08:00)

This topic contains 2 respuestas, has 2 mensajes.

Last updated by marcusC-4 hace 2 años, 8 meses.

Assigned support staff: Luo Yang.

Autor
Mensajes
#1552207

I can only view the map on this page if I'm logged in: hidden link

I think it could be a conflict with Autoptomize. Is there a js file that I should exclude from being deferred?

#1553001

Luo Yang
Supporter

Languages: Inglés (English ) Chino simplificado (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Hello,

I am not sure which JS file you can exlude, since those JS files might be required by other plugins/theme, if you exclude any JS file, it might conduct other unexpected result.

Since it is a compatibility issue, I suggest you try to locate the problem plugin/theme first:
1) Deactivate all other plugins, and switch to wordpress default theme 2020, deactivate all custom PHP/JS code snippets, and test again

2) If the problem is fixed, activate other plugins/theme one by one, try to locate it.

#1553879

Thanks for the reply. I'll go through the troubleshooting steps as suggested and see what I find. I assume this is a conflict with Toolset and the cache settings since I can view the page when I'm logged in. Must be something that is deferred or combined that isn't playing nicely. I thought maybe this has come up before but no worries. I appreciate the suggestions.