Skip Navigation

[Resuelto] Delete link doesn't refresh page

This support ticket is created hace 9 años. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 10:00 – 19:00 10:00 – 19:00 10:00 – 19:00 10:00 – 19:00 10:00 – 19:00 -
- - - - - - -

Supporter timezone: Europe/Madrid (GMT+01:00)

This topic contains 16 respuestas, has 2 mensajes.

Last updated by alysiaC hace 8 años, 11 meses.

Assisted by: Caridad.


I entered a CRED delete shortcode...this one:

[cred_delete_post_link class="cred-refresh-after-delete" text="Delete" action="] 

It works perfectly except after I click the delete link it just says "deleting..." and never refreshes the page. When I refresh the page manually, the post is gone.

I tried deactivating all my plugins and the problem persists.

Any ideas on why this might be happening or how I can get the page to delete?



Can you try specifying the action attribute?

[cred_delete_post_link class="cred-refresh-after-delete" text="Delete" action="trash"] 




Yes, sorry. That part is in there too. The code got cut off when I copy and pasted. Any other ideas?


I've tried this on a fresh install and its redirecting.

Can you share access to your Dashboard to review the problem in depth? I have marked your next reply as private.

Let me know how the steps I need to follow to test your Delete button.



The HTTPS plugin has got to be the problem. I will try the reproduce it and inform our developers for fixing.

Just to confirm this is the issue, did you try to delete with this plugin disabled?



Yes. With the plugin is disabled, the delete link works correctly and the page is refreshed.

When the HTTPS plugin is activated, the delete link works but the page is not refreshed and it just says "deleting..." until I manually refresh the page.

Thanks for your help. If your developers can figure this out, it would be amazing. I really need a delete link and I need to have my SSL enabled.


Our developers have confirmed the issue and it will be fixed for next release.

I can send you a beta version as soon as its fixed.



We should have this fixed now.
I will send a development version to your email address.
Do you want to confirm?



Please send it to my email.


Hi Caridad,

Thanks so much for sending that over and getting it worked on so quickly. I really appreciate you and your team working to solve my issue. Unfortunately, the issue persists. I'm not sure what else to try, any ideas?

Thanks again.


I just tried to delete an entry in progress-log and it worked.
Can you double check this? Or let me know what steps to follow.

We must be doing something different.



It worked because I have the SSL plugin deactivated currently. I don't know what happened but now I get a redirect loop whenever I activate it. Can we put this issue on hold while I figure out the best way to implement my SSL?


Okay, redirect loop figured out. Still having the delete issue. If you go in and try it now, you will see that it doesn't refresh. As a work around, for now, I changed the text so that it says "deleted" instead of "deleting..."


When I add an entry, I end up being in secure mode. And while I'm in secure mode the refresh is working.

But I did notice that if I visit progress-log in non-secure mode, the refresh doesn't work.

How did you resolve your SSL issue? Because it looks related, let me explain: WordPress thinks its in SSL mode when its not.

Specifically, can you let me know what SSL settings you have in wp-config.php



I see what you're saying.

Originally, I was using the HTTPS plugin. An issue was being caused with another plugin so I removed the HTTPS plugin. This code was added to my wp-config file:


However, I don't want to use SSL on pages that aren't processing payment information so now I'm using the HTTPS plugin again to force HTTP on non-payment pages.

So, would the solution be to use a secure environment on pages where I need the delete function?

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.