Skip Navigation

[Resuelto] Date Field isn't working. No calendar pops up

This support ticket is created hace 6 años. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 13 respuestas, has 4 mensajes.

Last updated by grantD hace 6 años.

Assigned support staff: Adriano.

Autor
Mensajes
#393185

I am trying to use a date field on my site and input box and calendar button aren't working. Nothing happens when I click on either.

URL: hidden link

I've already checked for javascript errors and updated all my plugins to try and resolve this but it's still happening

You may need to login to view the page. I can send you an admin login to the site if you open up a private reply.

#393264

On the URL you shared I do not see any content.

As you say, it's hidden from Guests.

I will enable the Private Form so you can submit me the required details.

I need to confirm, Is this a issue in CRED?
Behause Types by itself will not let you create Front End Editable Calendar (Date Fields)
It only will display the Date selected.

If this is about Types, can you elaborate where and how the issue happens?

Thank you

#394282

Shane
Supporter

Languages: Inglés (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Grant,

Beda is not in today so i'll be filling in 🙂

I tried the credentials but was unable to log in.

Could you check on them and let me know

Thanks,
Shane

#394430

I've just fixed the login. Try it again now

#394579

The Login works but when I want to see as example the Toolset Settings page, I get 500 Bad gateway

This is a Server problem.

What I need is this:

1. A Toolset only form/website, as currently, the Form is highly modified with some non-CRED CSS and JS.
Probably your Theme or another plugin.

2. I need to play with the Toolset Settings for the Forms (with and without CRED CSS and / or Bootstrap)

3. To sum up, can you replicate the issue with Toolset only and a native WordPress Theme?

If not, we can narrow down the issue by reactivating every Plugin and Theme once by one.

It might also be Custom HMTML or CSS you use in the CRED Form.

Can you ensure it's a CRED form created with the "AutoGenerate" button?

Thank you

#394897

Hi Beda,

The 502 gateway error is an unrelated server issue I'm discussing with my host. It only lasts for about 15seconds before everything returns to normal.

What I've done so far:

- Copied my site to staging3.balifoodsafari.com (HTTPAUTH: balifood:dev123)
- Created a new CRED form and used auto generate
- Displayed it on a new test page : hidden link
- Disabled plugins likely to interact with its execution: iThemes Security, WP-Rocket
- Checked Console for any JS Errors (none)

At this point the error was still occuring.

I then swapped to TwentyFifteen theme and the field worked correctly. So the issue is a conflict between the theme and the CRED form.

Any idea what the conflict could be or how to resolve?

#394929

It's probably a AJAX / JS Library conflict.

Please send me the Theme in a Zipped File via Google Drive or DropBox, and it the Theme is a active supported Theme where we can reproduce the problem and contact the Author we can try to get in touch with them

Then we perhaps can work on a fix.

Not always the solution can be provided by use, as it might depend on cooperation of the 3rd Party Software developers.

Thank you for your patience and collaboration.

#394941

Theme download link:

hidden link

#394984

Downloading the Theme now.

I'll update you here as soon I have more results.

#395253

The issue is reproduced but this is the Theme's "fault", CRED works just fine with many other WordPress Themes out there.

I escalated the issue to our DEV for the porpoise to get in touch with the Theme DEV Team.

Please can you contact your Theme's Developers and inform them, that there is a Conflict with the CRED Plugin, and ask if they are willing in a Co-Work with Toolset Developers to solve this issue?

Thank you

#395363

Hello,

I’m Adriano, Toolset support lead and I have been escalated to this thread. I’ll give my best to help you to achieve your needs through Toolset components.

I've spent some time testing this and it ended up being a CSS issue in the theme. Adding the CSS below will solve the issue:

.content {
	position: inherit;
}
#395418

Hi Adriano,

Thanks for the assistance! That css snippet has appeared to have fixed the issue.

If you don't mind could you explain how the position of the content div set to relevant breaks the datepicker?

Does it cause the calendar popup to display off the visible page or something?

#395430

Not sure really, but the position:relative may be taking the calendar to another place.

#395479

Ok, no problem if you're not entirely sure, just thought if there was an explanation for it it's something I'd be able to catch and work out myself next time.

Thanks again for all your assistance working through this issue 🙂