Skip Navigation

[Gelöst] WordPress admin is not displaying option to update plugins.

This support ticket is created vor 7 Jahre, 5 Monate. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- - 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00
- - - - - - -

Supporter timezone: Asia/Ho_Chi_Minh (GMT+07:00)

This topic contains 4 Antworten, has 2 Stimmen.

Last updated by Vladimir vor 7 Jahre, 5 Monate.

Assigned support staff: Beda.

Author
Artikel
#326263
update-visible.jpg
update-no-visible.jpg

Hello,
I'm experiencing problems with Views and WPML updates. Link to plugin update is not visible until I click on Registered (plugin-install.php?tab=commercial). Than update links and round icon with number of updates are visible in admin. But it disappear after few reloads of admin.

It happends only for Views and WPML, not for Types. Probably only for plugins which has to be registered.

Screenshots attached.

Thanks for help.

#326277

Thank you for contacting us here in the Support Forum

I was able to reproduce this issue initially, but then , following those below steps, not anymore.

1. I firs updated Views (Toolset) Plugins, and then the WPML Plugin missed the update message/buttons
2. I disabled and removed Views and reinstalled it completely, and that solved the issue
(Of course my plugins are correctly registered form y site)

Does that help in your case to?

To remove and reinstall safely Views Plugin you can follow these instructions

★ INSTRUCTIONS:

❌ Backup your website and database ❌
• Deactivate/Delete the "Installer" plugin (if you have it)
• Deactivate Views plugin
• Login via FTP to your wp-content/plugins folder
• Delete the Views Plugin folders
• Go to https://toolset.com/account/downloads/ and download the latest stable View Plugin, then extract it.
• Upload the plugin via FTP to the wp-content/plugins folder.
⌥ alternatively you could upload the .zip file using Dashboard > Plugins > New > Upload
• Register the Plugin for your site
⌥ you can do that under Dashboard > Types > Installer

Please remember that WPML is not to update in any case if you have ongoing ICanLocalize Translation Jobs on your site.

If you have active ICL accounts, WPML omits the update automatically. And you should not update WPML if you have some ICL jobs ongoing. More information on this you can receive in the WPML forums:
https://wpml.org/forums/forum/english-support/

Please don't hesitate to inform me in case the issue persists

Thank you for your patience.

#326279
missing-installer.jpg

Thanks for help, I'll try to reinstall Views.

One more thing, on fresh installed WP site with registered Types and Views is missing Installer link (images attached). I'm sure there was one in previous versions of Types. Installer is accesible only via Plugins -> Types -> Registered

#326288

Thanks for the Details

I am consulting within the Types DEV team whether that Menu Item is removed on porpoise or if it's a BUG.

Meanwhile you can access that same Screen via
Dashboard > Plugins > New > Commercial,
or,
Dashboard > Plugins > any_toolset_plugin > Register/Registered

Please let me know if the fresh install solves your issue mentioned initially.

Please don't hesitate to inform me in case the issue persists and expect my informations here in the forum in regard of the Installer Menu Item

Thank you for your patience.

#326298

Looks like its fixed after reinstall. This problem appears on more of my sites, so I'll update it this way.

Thanks