Skip Navigation

[Gelöst] WooCommerce search error with WP Views activated

This support ticket is created vor 8 Jahre, 6 Monate. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Hong_Kong (GMT+08:00)

This topic contains 16 Antworten, has 3 Stimmen.

Last updated by willem-siebeS vor 8 Jahre, 4 Monate.

Assigned support staff: Luo Yang.

Author
Artikel
#240791

Juan
Supporter

Timezone: Europe/Madrid (GMT+01:00)

Hi Willem

Oh, yep, I should review my comments for a fourth time before posting them it seems 🙂

What I really ment is "Our solution is basically to check if using a WordPress Archive and also if the actual loop contains no result, and if both conditions are happening, we use the handy WooCommerce filter to disable that redirect feature".

If the loop contains no results, we disable the redirect before creating our dummy fake post, so it solves the main issue. If the loop contains any result, we let WooCommerce handle it: if it contains one result, do the redirection; if it contains more than one result, do not redirect.

Sorry for the confusion and I'm happy to hear that this is working fine for you 🙂 If you have no further question, please mark this ticket as resolved.

Regards,
Juan de Paco

#240793

Hi,

Yes, that makes even more sense and now I also completely understand it!

Thanks again (both).

Kind regards,

Willem-Siebe Spoelstra