Skip Navigation

[Gelöst] Warning notice releated to toolset.

Dies ist das technische Support-Forum für Toolset – eine Suite von Plugins zur Entwicklung von WordPress-Websites ohne PHP-Pogrammierung.

Jeder kann in diesem Forum lesen, aber nur Toolset-Kunden können darin Beiträge veröffentlichen. Der Toolset-Support arbeitet 6 Tage pro Woche, 19 Stunden pro Tag.

This topic contains 6 Antworten, has 2 Stimmen.

Last updated by romanF vor 1 Jahr, 1 Monat.

Assigned support staff: Minesh.

Author
Artikel
#1715543

Dear support,

I have quite a few warnings related to toolset lately. And I am not sure why. Some of them seem to be related to the captions of the image gallery.

Notice: Trying to access array offset on value of type null in /www/htdocs/w01ab6af/moinzukunftforum.de/wp-content/plugins/cred-frontend-editor/vendor/toolset/common-es/php/Rest/Route/ShortcodeRender/WithMeta.php on line 74

Notice: Trying to access array offset on value of type null in /www/htdocs/w01ab6af/moinzukunftforum.de/wp-content/plugins/cred-frontend-editor/vendor/toolset/common-es/php/Rest/Route/ShortcodeRender/WithMeta.php on line 78

Notice: Trying to access array offset on value of type null in /www/htdocs/w01ab6af/moinzukunftforum.de/wp-content/plugins/cred-frontend-editor/vendor/toolset/common-es/php/Rest/Route/ShortcodeRender/WithMeta.php on line 79

Notice: Trying to access array offset on value of type null in /www/htdocs/w01ab6af/moinzukunftforum.de/wp-content/plugins/cred-frontend-editor/vendor/toolset/common-es/php/Rest/Route/ShortcodeRender/WithMeta.php on line 81

Notice: Trying to access array offset on value of type null in /www/htdocs/w01ab6af/moinzukunftforum.de/wp-content/plugins/cred-frontend-editor/vendor/toolset/common-es/php/Rest/Route/ShortcodeRender/WithMeta.php on line 74

Notice: Trying to access array offset on value of type null in /www/htdocs/w01ab6af/moinzukunftforum.de/wp-content/plugins/cred-frontend-editor/vendor/toolset/common-es/php/Rest/Route/ShortcodeRender/WithMeta.php on line 78

Notice: Trying to access array offset on value of type null in /www/htdocs/w01ab6af/moinzukunftforum.de/wp-content/plugins/cred-frontend-editor/vendor/toolset/common-es/php/Rest/Route/ShortcodeRender/WithMeta.php on line 79

Notice: Trying to access array offset on value of type null in /www/htdocs/w01ab6af/moinzukunftforum.de/wp-content/plugins/cred-frontend-editor/vendor/toolset/common-es/php/Rest/Route/ShortcodeRender/WithMeta.php on line 81

Notice: Trying to get property 'ID' of non-object in /www/htdocs/w01ab6af/moinzukunftforum.de/wp-content/plugins/toolset-blocks/vendor/toolset/blocks/server/Block/Gallery/Shortcode/AltText.php on line 43

Notice: Trying to get property 'post_excerpt' of non-object in /www/htdocs/w01ab6af/moinzukunftforum.de/wp-content/plugins/toolset-blocks/vendor/toolset/blocks/server/Block/Gallery/Shortcode/Caption.php on line 41

Notice: Trying to get property 'ID' of non-object in /www/htdocs/w01ab6af/moinzukunftforum.de/wp-content/plugins/toolset-blocks/vendor/toolset/blocks/server/Block/Gallery/Shortcode/Caption.php on line 45

Notice: Trying to get property 'ID' of non-object in /www/htdocs/w01ab6af/moinzukunftforum.de/wp-content/plugins/toolset-blocks/vendor/toolset/blocks/server/Block/Gallery/Shortcode/AltText.php on line 43

Notice: Trying to get property 'post_excerpt' of non-object in /www/htdocs/w01ab6af/moinzukunftforum.de/wp-content/plugins/toolset-blocks/vendor/toolset/blocks/server/Block/Gallery/Shortcode/Caption.php on line 41

Notice: Trying to get property 'ID' of non-object in /www/htdocs/w01ab6af/moinzukunftforum.de/wp-content/plugins/toolset-blocks/vendor/toolset/blocks/server/Block/Gallery/Shortcode/Caption.php on line 45

Can you help me to fix them?

#1715571

Minesh
Supporter

Languages: Englisch (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

Can you please share debug information so that I know that what PHP version you are using and in addition to that could you please also share the problem URL where I can see the notice?
=> https://toolset.com/faq/provide-debug-information-faster-support/

We have related ticket reported by other user but that seems to be resolve by updating the PHP version as you can see with the following user reply:
=> https://toolset.com/forums/topic/php-notice-trying-to-access-array-offset-on-value-of-type-null/#post-1706773
=> https://toolset.com/forums/topic/php-notice-trying-to-access-array-offset-on-value-of-type-null/#post-1707013

#1715573

Thank you Minesh for your support.

I downgraded my PHP version from 7.4 to 7.3 but the messages still are visible.

hidden link
or here
hidden link

if you start editing the template for "Angebote" a few warnings appear first and then disappear when the content to work on the template shows up.

One thing that might be interesting to notice is that the website ran on 7.4 for quite a while without problems. So I am not sure if this is really the cause.

#1715577

Minesh
Supporter

Languages: Englisch (English )

Timezone: Asia/Kolkata (GMT+05:30)

Indeed there seems to be some issue but this needs to be investigated deeply.

In order to minimise the cause of the issue and rule out any possible conflict:
Could you please try to resolve your issue by deactivating all third-party plugins as well as the default theme to check for any possible conflicts with any of the plugins or themes? - Do you see any difference?
- If no:

I will require duplicator copy of your site in order to troubleshoot this issue further.

Can you please send me duplicator copy of your site:
=> https://toolset.com/faq/provide-supporters-copy-site/

I have set the next reply to private which means only you and I have access to it.

#1715599

I tried to simply delete the Custom Type Posts that had the warnings and tried to add a new one to see if this resolves the issue. And as far as I can see it does.

#1715607

Minesh
Supporter

Languages: Englisch (English )

Timezone: Asia/Kolkata (GMT+05:30)

That is really strange.

So again, just like another reference ticket I shared, I am clueless as there is no issue or not able to identify whats causing the issue. You are feel free to mark this resolved.

#1715651

My issue is resolved now. Thank you!

Das Forum „Toolset Professioneller Support“ ist für neue Themen und Antworten geschlossen.