Skip Navigation

[Gelöst] Views generated image links need to be updated

Dieser Thread wurde gelöst. Hier ist eine Beschreibung des Problems und der Lösung.

Problem: Several custom field images are showing the wrong URL. It appears to be generated using the original image guid.

Solution: Update to Types 3.2 to get the fix for this bug.

This support ticket is created vor 4 Jahre, 2 Monate. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 - -
13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 - -

Supporter timezone: America/New_York (GMT-04:00)

This topic contains 22 Antworten, has 3 Stimmen.

Last updated by Christian Cox vor 4 Jahre.

Assigned support staff: Christian Cox.

Author
Artikel
#1120855

Okay thanks, I was able to make a site clone and I have deleted it from your server. When I installed the clone on my local site, I was able to see the issue, so I ran some tests. First I noticed that your wp-config.php file is limiting the amount of available memory to only 128MB, yet we recommend a minimum of 256MB - https://toolset.com/toolset-requirements/. So I modified that line and added an additional line to manage the memory in wp-admin:

define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Then I cleared the image caches once more in Toolset > Settings, and now the image URL on the homepage is as expected:

<img src="<em><u>hidden link</u></em>">

So I'm curious if the allocated memory was limiting the backend process that clears out the cache. I get an error when trying to log into the FTP account you gave me, so I'm not able to test this myself on your server. Can you try updating your wp-config.php file, then clear your image cache again in Toolset > Settings > Custom Content?

#1120870

Great detective work, thanks Christian. On your cloned site, what effect did those actions have one the properties on the prestige page? I have just done as you suggest and it did indeed fix that one image on the home page, but unfortunately not elsewhere, as many of the prestige URLs are still the old ones.

#1120966

Okay it didn't resolve the Prestige page right away, so I did a few more things:
- Edit the page in wp-admin and add cached="off" to the two View shortcodes:

[wpv-view name="prestige" cached="off"]
[wpv-view name="featured-house" cached="off"]

- Flush the image caches again and re-save site permalinks for good measure

Now I still see a few image URLs with /test/, but they are only for images I did not download from your site. When I made my site clone, I only included wp-content/uploads/2018/09, and the /test/ URLs are all for 2018/07. Since the originals cannot be found, the resized versions cannot be created, hence the cache does not get updated for those images.

#1121505

Hi Christian

It is exactly those 07/18 ones that are the problem and on the live site it's not because the originals are not there (they are), I think it's that those are the properties that were added while the site was at /test. I'm not sure if it makes any difference, but they were imported using WP All Import, in July 2018, to the site in the /test folder. They all have the correct URLs in the database, and on their individual pages, just not in the views where they are listed together in a grid.

I see you added cached="off" to the prestige view on the live site, and I have just cleared all caches again, and re-saved permalinks, but there are still 9 properties (all from July) on that page with the test URLs.

Thanks for your persistence!
Zoë

#1122974

Okay thank you for your patience, I'm passing this ticket to my 2nd tier support team now. Even after downloading the images to my local environment, I'm unable to update the URLs by clearing the cache of images and turning off cache in the Views. I have deactivated all other plugins except Types and Views, and I've activated a default theme. I even resaved a post with test URL images, but couldn't get the URLs to update. So at this point I need to get some additional assistance. I'll let you know what I find out from 2nd tier support.

#1129240

Okay I have an update. The issue with old URLs appearing will be resolved in Types 3.2, and in the meantime you can remove the size="large" attribute from the Types field shortcode as a workaround:

[types field='property-photo'][/types]

Or in inline CSS:

background-image:url([types field='property-photo' url='true'][/types]);

Apparently the problem is only occurring when specific sizes are applied. I'll keep you posted here as I receive more information.

#1129260

Thank you, I'll just sit tight and wait for the next release then.

#1155517

Hi, Types 3.2 is now available for download or automatic update. Please update to the latest version of all Toolset plugins and let me know if the problem is not completely resolved.