Skip Navigation

[Gelöst] View not respecting query filter settings

This support ticket is created vor 7 Jahre. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Heute stehen keine Supporter zur Arbeit im Werkzeugsatz-Forum zur Verfügung. Sie können gern Tickets erstellen, die wir bearbeiten werden, sobald wir online sind. Vielen Dank für Ihr Verständnis.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Hong_Kong (GMT+08:00)

Dieses Thema enthält 2 Antworten, hat 2 Stimmen.

Zuletzt aktualisiert von ashleighP vor 7 Jahre.

Assistiert von: Luo Yang.

Author
Artikel
#547158
debug tool shows empty query.png
the one labeled
shortcode with parameter.png
parameter in the view edit page.png

I am trying to: create a view that is filtered by a custom usermeta field

I visited this URL: versteckter Link

I expected to see: a view that shows users but only with the custom user meta field "wpcf-user-role"
of Host

Instead, I got: All users are listed and debug tool shows an empty query

#547224
filter.JPG

Dear ashleigh,

In your screenshot:
versteckter Link
You are using a filter which is filtered by browser URL parameter "filterbyrole"

But in your screenshot:
versteckter Link
You are pass the attribute "filterbyrole" to view shortcode [wpv-view]

They are different, one is URL parameter, the other is shortcode attribute.

I assume you are going to filter the view result by shortcode attribute, please modify the filter the view, your screenshot:
versteckter Link
To:
Select items with field:
wpcf-user-role is a string equal to VIEW_PARAM(filterbyrole)

see my screenshot filter.JPG

#548130

...and it's fixed. Sorry for the bother I must have been really tired!

Dieses Ticket ist jetzt geschlossen. Wenn Sie ein Toolset Kunde sind und Hilfe benötigen, eröffnen Sie bitte ein neues Support-Ticket.